1

I'm on rooted MIUI 10 8.8.9 Android 8.1

Currently there is WebView version 62.0.3202.84 installed inside /system/app/WebViewGoogle/WebViewGoogle.apk with /oat/arm and /oat/arm64 directories containing *.odex and *.vdex files

I've tried to just install newer *.apk, but I get following error "Can't install system applications from unofficial channels".

  • On Android 8 the WebView component is no longer needed. Just install the Chrome app and deinstall/deactivate the WebView. Chrome will then be used as WebView. You can check that in the developer settings (search for "WebView"). – Robert Nov 4 '18 at 14:49
  • @Robert I've tried that, but WebView setting in Developer settings became empty and I got a lot of crashes in apps that use WebView. Maybe Xiaomi changed something in MIUI. – janot Nov 5 '18 at 0:47
  • I've tried to update to newest version 70 apk and it just worked. No idea, why.. – janot Nov 5 '18 at 0:55
1

Looks like MIUI's Package Installer is blocking updates of system apps, so you have to disable "Turn on MIUI optimization" in "Developer options". After that system starts using Android's Package Installer which behaves as expected and allows to update.

Note that if you want to reenable "Turn on MIUI optimization" option, you'll have to reboot your device after that for everything to work again (e.g. your device may stop receiving sms from short numbers).

0

In settings you need to enable install from Unknown sources.

Go to settings - > Additional Settings > Privacy -> Unknown sources.

  • If you just want to update webvew you can do that from playstore – m__ Nov 4 '18 at 12:30
  • I had this setting enabled, but I got that error from my question anyway. Also I don't have Google Services installed, so I'm not able to just update from Play Store. I'm using Yalp Store for that. Thanks to your answer I've tried to update to newest version 70 apk and it just worked. No idea, why.. – janot Nov 5 '18 at 0:43
  • Happy to hear. Good luck. – m__ Nov 5 '18 at 2:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.