0

So I've tried to update the device, or - to be more specific - downgrade it from android 6 to 5 with an official firmware to do so. When I started, phone was at 100% battery, but the process bar got stucked for about 30 minutes at about 20%. I decided to turn the device off, in hope to just reset it, but it didn't turn on again.

when I hold the power button, i do feel the 2 vibrations, like I normally would when starting the phone. the screen stays black and nothing happens.

I tried to hold vol down and power, as well as vol up and power, but neither worked. How can I restore the phone? I don't mind loosing data - I've backed up everything yesterday.

  • That device is "Deadboot" or hardbricked. The best thing to do is to restore/re-flash it's firmware through PC. This will help. – TerribleDog Sep 11 '18 at 7:23

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.