Is android 9 sdk installation not compatibile with jdk 8 for running avd ? I tried running but got error of;

"emulator: ERROR: ANDROID_SDK_ROOT"
emulator: ERROR: This AVD's configuration is missing a kernel file! Please ensure the file "kernel-qemu" is in the same location as your system image.

It is compatible with jdk 8 (which is what I have in my setup). Perhaps you need to setup its path correctly in System Variables.

Not sure what the result of this was, but I have encountered the same error when I first ran android 9 on standalone sdk manager. What I did in my case was to upgrade the emulator, which altogether solved the issue, perhaps is the same scenario, firstly try upgrading the emulator and see if it solves the issue.

You can also try editing image.sysdir.1 value to a full AVD path e.g image.sysdir.1=C:\androidsdk\system-images\android-28\google_apis_playstore\x86\ as suggested by Akintunde

(I see some suggestions that you should rename kernel-ranchu to kernel-qemu in the system image folder but this didn't work as I hoped, the AVD screen just went black.)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.