1

I just upgraded my Samsung Galaxy S5 from Android 6 to LineageOS 15.1, and now ADB does not want to access my phone any more. All I get is:

% adb shell
error: insufficient permissions for device: verify udev rules.
See [http://developer.android.com/tools/device.html] for more information.
%

The connection gets thus rejected without me getting any prompt on the phone's side.

I tried it both from a "Debian stable" and a "Debian testing" machine, and both of those have no trouble accessing my other phone.

Obviously, I have enabled the "USB debugging" option on the phone, which when connected correctly says "USB debugging connected". I tried to kill&restart the ADB daemon but that didn't help either.

Any looked at the referenced web page, but I didn't find anything there that gave me a clear idea of what might be going on or what I might try to do to track it down. Any idea?

  • 2
    When you plug the phone to the computer, choose to use the phone as a MTP device and then try adb shell again. – Death Mask Salesman Sep 14 '18 at 18:20
  • Define udev for device as explained here android.stackexchange.com/q/144966/131553 – beeshyams Sep 14 '18 at 18:26
  • @DeathMaskSalesman: I do not understand the logic of it, but what can I say: it worked! Thanks a lot! – Stefan Sep 14 '18 at 18:27
  • 1
    @Stefan I don't understand it as well, but the Galaxy S3 suffers from the same bug (?) and that workaround does the trick. – Death Mask Salesman Sep 14 '18 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.