1

Apologies if this has been answered already. I searched and found many variations on this issue, but nothing that applies directly to my situation. At first, I thought my old off-brand cable was to blame, but after using the same cable/base/outlet to charge my wife's phone (also an S7) to get a nearly complete charge within an hour, I've determined that it is an issue with the phone.

My S7 charging time has gotten slower and slower over the last week or so. It went from regularly fast charging to mainly standard charging at first...and I'm now at the point where it goes from charging to fast charging to not being connected at all...and then through the cycle again, but in no particular order, and without the phone being moved. Sometimes it's (fast or not) charging, sometimes it's not charging at all. Regardless of what it says it's doing, it's barely maintaining a charge, let alone making any progress. It has never said that it's charging slowly. I've seen that message before when I was using an older cable that was due for replacement. Not present here. It's charging very, very slowly even when it's stating an at least regular charging state.

Having already ruled out a cable/base/outlet issue, I've tried closing all apps and even turning the phone off. I also cleaned lint/dust out of the charging port. Nothing has helped. After cleaning and then turning my phone off last night at 18%, I woke up to a 91% charge seven hours later. The phone downloaded and installed the latest update to 8.0.0 (Oreo) earlier this week. This issue pre-dated the update, but I can't say for sure if it was worsened by the software change.

Every page/post that I've come across so far has at least one variable that makes the situation different from mine. Any thoughts or ideas would be greatly appreciated. Thank you in advance!

  • 1.Put the phone in safe mode and charge. If it charges as it should it indicates a problem with some installed app 2. is the result same if you tried charging with your wife's device cable? If no, it is a cable device combo issue, never mind it charges fine on her device – beeshyams Sep 17 '18 at 12:04
  • You should check the phone USB connector for dirt, debris etc... And if possible bring it to a phone repair shop, as this might a hardware failure, they should fix it – esQmo_ Sep 17 '18 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.