1

Google maps history worked perfectly with my old phone.

Now I have a new one and maps history worked for the first few days, then it started to behave randomly: when it works the data is correct, but most of the time it does not track anything.

If I open maps and use the gps it finds my position immediately, but even doing so the tracking is not triggered.

I already tried to deactivate and reactivate it and google play services, as well as clear the cache both for maps and play services.

I checked battery optimization and set maps and google play services to manual mode, setting them in the most active status possible.

It seems that if I restart the phone for a few hours the tracking is correct, then it stops.

I already contacted the phone manufacturer (Huawei) and made all the suggested steps (clear cache) I did not perform the factory reset that they suggested as last resort because the phone has less than 2 weeks.

I think that some battery optimization on the phone (p20 PRO) kills some process needed for maps history, that's why restarting the phone fixes the problem for a few hours.

Can you suggest me some further troubleshoot step? 

I also considered to use tasker to force the execution of some process in order to keep alive the needed services but I would need some advice about what to call to keep alive the history.

  • I noticed a similar behaviour, and wondered if it was a change of precision coming from Maps itself, since now I mostly see my start point and arrival. Did you get any solution? – Patrick Honorez Nov 20 '18 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.