i installed android-x86-4.2-20130228 as a live but does'nt read my partition of my hardisk i tried with Paragon UFSD Root Mounter but not work good in 4.2.2 and es explorateur does'nt read any partition


i think that you could mount your partition from your hard disk with the mount command.

Usually all partitions are avalaible in /dev/block/.

So you could check what is mounted by typing "mount" in a terminal emulator app or through adb (computer).

After that, u could comparring the partitions names with an ls -al /dev/block/ command.

After that u could have a better idea of wich partition name is your hard disk. Usually, and depending on how you have connected your hard disk to your android-X86 (SD or USB or by other method(s)), the partition block have "mmc" is it name.

Finally, you could mount your partition with theses followed command:

mkdir /hard-disk-partition
mount -t FAT32 -o rw /dev/block/partitionname /hard-disk-partition

-t argument is used to define the partition filesystem
-o argument is used to define the access type

-r is for read only -rw is for read and write -rwx is for read, write, and execute

I think that -t and -o arguments are sufficients for your usage.

Ah, and before i forget, it's possible that you have to install an "all-in one toolbox" like Busybox or Toybox, because maybe that some applets commands aren't installed on your Android system (/system/bin and /system/xbin/), it will be usefull if u have to use commands like egrep, sed or awk for exemple.

  • When i use mkdir /hard-disk-partition it show me : mkdir failed for /hard-disk-partition, Read-only file system and when i use mount -t FAT32 -o rw /dev/block/partitionname /hard-disk-partition it show : mount : no such file or directory – Tifik aoryu Sep 28 '18 at 16:21
  • For the first command output, it say that your system partition is mounted in read-only mode, because / is a part of the system partition. You could try to reboot in a custom recovery mode as twrp for exemple to be sure to be able to mount your partition, or u can create the new folder in /sdcard/. – Rom Sep 29 '18 at 16:59
  • I didn't find how can i install twrp in android x86 – Tifik aoryu Oct 1 '18 at 10:39
  • Have u a smartphone device with Android and x86 processor or it's an vm with android-x86 installed ? In case of the device, please say the manufacturer and the model. – Rom Oct 2 '18 at 15:39
  • i installed android x86 daul boot with windows – Tifik aoryu Oct 4 '18 at 8:39

Peace be with you! I have tried a lot search on Google and then at last I successfully done it. Now I tell you how to do it. Let's begin! 1)Open the terminal 2)Give following commands


mkdir /mnt/windows

ntfs-3g /dev/block/sdax mnt/windows

Note: x is the number of your drive which can be 1,2 or 3 etc.

3)Now open File manager named Super File Manager. If you have not installed then install using the link below:


4)Go to settings, scroll down and check Root Explorer

5) Navigate back from the settings and there a tab will appear named /Root .Click this tab and find /mnt directory there.Open it and find folder named window within this directory. Open it also and there you will find your ntfs drive of windows environment.

Tell me if any problem!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.