0

I have a Samsung Galaxy S7 SM-G930F that is fully functional with the exception of the screen and probably the capacitive buttons too. All I really need to do is to access my files. As a minimum, I need to access the files in /storage, but it would be nice to get all the application data as well. The phone has no custom recovery, only stock recovery and it isn't rooted; the worst part is that USB debugging is disabled. I also tried to enter my pin by plugging a keyboard and mouse to the phone via OTG, but neither device was recognised, and even if the mouse were recognised, I can't see anything on the screen.

How would I access the ADB, turn USB debugging on, remove the pin, or at least get the files from the phone using only stock recovery?

0

This is a tough one, and I cannot comment on your question as such since I do not have enough reputation for that, but here's a couple of suggestions that may help you; (Desperate measures call for desperate means.. These are 'longshots' but may be some of few possibilities?) This is assuming that you do not want to just physically repair the device.

I'm only throwing this out here because I do not anticipate a simple, quick or easy solution/answer.

  • Borrow or get access to a similar device. Start from boot on both, run in parallel and try to get to USB Debugging or other 'endpoints'. For instance the PIN parts will be difficult. I'm assuming both that you know the PIN as well as the touch input for the screen works here.

  • You MAY be able to access the device with cable from PC without using ADB. You could try a terminal emulator like RealTerm to access the device as a virtual COM port and possibly use either the AT (ATtention) command set or other means to access the device, assuming you get a response on this level. This would require a lot of facts digging if at all possible. (Especially with this one I'd go for the repair option before spending all the time needed here which will probably end up with a fail.)

  • Thanks. The touch doesn't work, I've already tried to enter the pin using a screenshot of the unlock screen from google images and I don't get haptic feedback from touching the screen. Thanks for letting me know about the AT command set, I'll look into it. – u7w2 Sep 29 '18 at 22:51

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.