12

The info
Android version: 8.1.0
Phone: BQ Aquaris X Pro.
The phone ships with almost-stock Android. I am using Nova Launcher (not sure if important)

The situation
I have a Bluetooth headset on my motorbike's helmet wich supports both Bluetooth connection with the smartphone, and direct connection with another headset, but not simultaneously. So if I turn on my headset while my phone's Bluetooth is on, it connects automatically to my phone, before it connects to my partner's headset.

Until now, I was just fine disabling Bluetooth on my phone when needing to pair with another headset. But I just got an smartwatch, and every time I disable Bluetooth on my phone, when I enable it again, the watch connects to my phone and starts a painfully long a-gps updating process.

The question
How do I tell my phone not to connect to the headset automatically?

1
  • I recall there being a file somewhere within the kernel files or other data file within root directories where you can (with root, I assume) change the priority of devices through a numeric value. You might have to go down a rabbit hole to find it, though, gl!
    – Arctiic
    Jun 7, 2023 at 1:24

2 Answers 2

4

Unfortunately, there is no explicit setting "do not autoconnect" for a Bluetooth device (wish there were). However, there is a workaround (as mentioned in askvictor's answer):

  • In Settings, open the list of Bluetooth devices, and click on the cog icon next to a device.
  • The detail screen should show a list of all types of connections the device supports, such as "Phone calls", "Media audio" etc. (these represent the supported Bluetooth profiles).
  • Now disable all profiles.
  • The phone will no longer auto-connect to that device, though it will still remain paired.
  • The setting will persist even after restarting the phone or switching the other device on/off.

If you do want the phone to connect, open the list of Bluetooth devices, and tap on the device (not on the cog). It will then reconnect, with default profiles. This setting will also persist, use steps above to disable autoconnect again.

Tested on Android 12, but probably works on other versions, too.

0

In the Bluetooth settings for the headset, try selecting disconnect. This should disconnect it, until you connect again manually (I think). If that doesn't work, try switching off 'phone audio' in the Bluetooth settings for that device; but I'm not quite certain if you need to reenable that every time you want to use it.

2
  • 3
    It doesn't though. Whenever the bluetooth device gets powered on, android reconnects to it.
    – A-y
    Feb 17, 2022 at 18:15
  • This answer has the right idea, but could need expansion. I added an answer that should work, thanks for pointing me in the right direction!
    – sleske
    Jun 6, 2023 at 10:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .