1

Obviously, I have inadvertently changed some setting, but can’t figure out what.

I use K9 with 6 accounts, none of which have previously used encryption (I would prefer to – my correspondents wouldn’t). Suddenly all of them, when I try to compose an email have a red padlock at the top right and a tooltip appears at the bottom saying

“Cannot connect to crypto provider; check your settings or click crypto icon to retry”.

On the individual account settings, and also on global settings, the Cryptography tab shows :

  • OpenPGP App - None
  • Show unencrypted signatures – unchecked
  • Autocryptography Mutual Mode – unchecked.

I cannot find any other cryptography options and do not remember changing any. What might have caused it (a very slim chance, but I can think of nothing else) is that it first occurred when I used FireFox Focus, which is privacy oriented and always runs in private mode, to share a link to a web page. Perhaps that changed some setting?

Well, it doesn’t really matter how it happened, but now I cannot send any mail without this error message.

How can I disable cryptography in K9?

1

This is a bug reported four months ago and unresolved as you can see here. The context is different but the error message is the same. One solution that worked for somebody is

Workaround is to manually start the cryptoprovider (OpenKeyChain), then reopen k9 and tap on the lock sign, then sending works for me... The problem is the operating system preventing openkeychain to start automatically or being started by k9

This happened to me too recently (and I didn't know this was a bug). I backed up K9 and Open Keychain using Titanium Backup, uninstalled both, restored only K9 and it worked. Much latter, restored Open Keychain and set it up globally and per account and all fine

If either of these solutions don't work, you may well add your experience in the bug tracker and post resolution or what worked for you

OP has resolved the problem as per comments and requested this to be added to help others

I just exported all settings, uninstalled & re-imported....exporting settings & unchecking global settings when importing did the trick (I will have to go over those manually now)

  • I don't even have a crypto provider installed :-( I just exported all settings, uninstalled & re-imported. The problem persists. I will try again with only the account settings & report back – Mawg Oct 3 '18 at 10:11
  • 1
    Ok, exporting settings & unchecking global settings when importing did the trick (I will have to go over those manually now). If you add that to your answer, I will accept it, to help others. I wouldn't feel right posting my own answer, after the help you have given me :-) – Mawg Oct 3 '18 at 10:16
  • 1
    I wouldn't have minded answering, but didn't want to seem to "steal your thunder" :-) Not like you need the rep, but, as you say, the main point is that this will help others. – Mawg Oct 3 '18 at 14:16
  • 1
    I just got to the office & read this. I have downloaded it & will configure it at my break. A real clincher would be if it let me download all of my email and store in on SD card for offline access. – Mawg Oct 4 '18 at 7:04
  • I work in an office which is a Faraday cage, for security grounds. I could tell you more, but ... :-) Having a hugs SD card, I see no reason not to have all of my email available offline – Mawg Oct 4 '18 at 8:18
0

I had this problem, of not being able to send any message, encrypted or not, while OpenKeychain was installed. I tried a bunch of settings, and what seemed to work was uninstalling OK, waiting a few days to a week, then reinstalling OK. I imported all the necessary keys, and so far I'm able to send both unencrypted and encrypted messages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.