0

My device (Samsung J7 Prime, running the stock ROM) recently updated from Android version 7.0 to 8.0.

When I connect it to Android Studio and run the app, it successfully installs the app – but when it launches the app, my phone automatically restarts. Every time I run my app, it does the same. It works fine when it runs with Nougat (version 7.0).

Is it a phone problem – or my Android Studio is missing something? Basically whenever Android studio sends this command, phone restarts automatically:

$ adb install-multiple -r -t E:\Programing Files\AndroidStudioProjects\ProjectTorrent\app\build\intermediates\split-apk\debug\slices\slice_3.apk E:\Programing Files\AndroidStudioProjects\ProjectTorrent\app\build\intermediates\split-apk\debug\dep\dependencies.apk E:\Programing Files\AndroidStudioProjects\ProjectTorrent\app\build\intermediates\split-apk\debug\slices\slice_9.apk E:\Programing Files\AndroidStudioProjects\ProjectTorrent\app\build\intermediates\split-apk\debug\slices\slice_8.apk E:\Programing Files\AndroidStudioProjects\ProjectTorrent\app\build\intermediates\resources\instant-run\debug\resources-debug.apk E:\Programing Files\AndroidStudioProjects\ProjectTorrent\app\build\intermediates\split-apk\debug\slices\slice_6.apk E:\Programing Files\AndroidStudioProjects\ProjectTorrent\app\build\intermediates\split-apk\debug\slices\slice_1.apk E:\Programing Files\AndroidStudioProjects\ProjectTorrent\app\build\intermediates\split-apk\debug\slices\slice_0.apk E:\Programing Files\AndroidStudioProjects\ProjectTorrent\app\build\intermediates\split-apk\debug\slices\slice_7.apk E:\Programing Files\AndroidStudioProjects\ProjectTorrent\app\build\intermediates\split-apk\debug\slices\slice_2.apk E:\Programing Files\AndroidStudioProjects\ProjectTorrent\app\build\intermediates\split-apk\debug\slices\slice_5.apk E:\Programing Files\AndroidStudioProjects\ProjectTorrent\app\build\intermediates\split-apk\debug\slices\slice_4.apk E:\Programing Files\AndroidStudioProjects\ProjectTorrent\app\build\intermediates\instant-run-apk\debug\app-debug.apk

Solution:

I went to Samsung Officials and found that new update of Samsung J7 prime have some issues with adb commands, so I reversed back my android version to Nougat which solved my problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.