0

Posting this for the benefit of others, after failing to find the problem/resolution on my own.

Yesterday (Oct 2018), my Samsung J5 2016 phone failed to properly enable internet-wireless tethering. It never had a problem in the past, and I am fairly certain that I used tethering since date of the latest OS update (Jun 2018), at least in conjunction with an iOS device (iPad). But as of yesterday, tethering my Microsoft Surface Pro stopped working.

What actually failed:

  • DNS resolution

Things I tried:

  • I restarted the Android device
  • I restarted the client (Surface Pro/Win 10)
  • I renewed the DHCP lease. (ipconfig /renew)

What worked:

  • Pinging the device.
  • Pinging hosts by IP on the internet.
  • Manually configuring the interface to use a DNS server (8.8.8.8)
  • Manually configuring the interface to use the device as a DNS server (192.168.43.1)

What I did to resolve the issue:

First, on Windows, I used ipconfig /all to determine the DHCP assigned IP address and DNS addresses. I noted these two were different:

  • IP Address: 192.168.43.161
  • IP Address of Gateway: 192.168.43.1
  • DNS Address: 192.168.0.1

The DNS address looked bogus to me.

On the Windows device, I used Zenmap (nmap) to discover available ports, and saw that for 192.168.0.1, ports 80 and 443 were available, but not 53. I then did a scan of 192.168.43.1 and saw that 53 (UDP and TCP) were available.

  • This seems like a blended Q and A, which comes across more as a blog post. You should separate the Q from the A as separate posts. Contributors are allowed to submit answers to their own questions in that manner. – wbogacz Oct 6 '18 at 3:47
  • @wbogacz The answer is clearly separate. This utility of this site is not only for answering new questions, but pointing others to solutions for similar problems. By demonstrating what I tried in the Q, it becomes clearer why the A is the right one. – Otheus Oct 6 '18 at 15:51
0

After trying some solutions (such as adding "dun" to the APN Type), I finally did a reset of all networking settings and rebooted the device. The next time I started tethering, I noticed that it also reset the SSID and password of the tethering setup. I then recreated the SSID, but forgetting the password, I entered a new password. On Windows 10, I could not seemingly change the password, and was therefore forced to "Forget the Wireless Network" and re-connect to it.

One of these two steps solved the problem. I recommend first doing a "forget" on the Windows client, and if that doesn't work, "Reset Network Settings" on the device.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.