0

I have an Android phone, Lenovo vibe P1m. I had rooted it using my pc. One day I uninstalled SuperSU and tried to install Magisk. During this process, I don't know what happened but somehow the twrp recovery and the operating system got deleted. Then i booted my phone into recovery. Then my phone was stuck in boot loop. There was only a white screen with the brand name. After some days I tried to flash the stock firmware using sp flash tool on my laptop. When flashing was completed, I disconnected my phone from pc and switched it on. Now there is no white screen with phone's brand. There is only a black backlit screen. Now my phone has no OS, no recovery mode, nothing. Only a black screen. How to fix this?

1
  • Your comment @RahulGopi doesn't help. Oct 9, 2018 at 3:47

1 Answer 1

0

Although I've never had a Lenovo device, I have accidentally deleted my OS and recovery before.

Are you able to boot the phone into 'Download mode' (I would love to post a guide for you but, after a quick Google I couldn't find one)?

Download mode should still be available (it's used by the manufacturers to install the OS in factory) and hopefully you'll be able to connect your phone to a computer and re-flash the firmware.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .