1

A while back I installed nano on Termux and it worked fine, but when I accidentally tried to copy a file into a nonexistant directory at nano's location, nano wouldn't run. I checked and the executable is still there with the object code and all. If I chmod -x nano and run nano, it says nano has wrong permissions but using chmod +x nano and running nano says there is no such file or directory. The same thing happened when I tried installing Haskrll stack. First I tried installing a non-ARM version accidentally, but when I found the correct ARM executable, it had the same issue as nano. I've looked around for solutions and some answers to other questions say the issue could be trying to run from sd card but it used to work so I don't think that's it and don't know of a way to check. Also, all other executables in nano and stack's directory (and all other directories) work just fine.

  • 1
    Seems SELinux issue. Did you try restorecon or setting SELinux permissive? Secondly paths isuus occur when using absolute executable paths while LD_PRELOAD is set. – Irfan Latif Oct 18 '18 at 4:43
  • The thing is, I tried with UserLAnd it doesn't the same issue with stack. Passing binaries in between UserLAnd and Termux doesn't work unless I compile statically. I think the issue is, that as Termux's directories are organized differently, the binaries can't find the .so files. Could SELinux still be an issue? I don't really know what it is. Also, would you know why Termux and UserLAnd say the dynamic binaries don't exists when I try running them? – Benjamin Philippe Oct 19 '18 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.