2

I enabled google backup on my galaxy S8 this morning. Photos synced in a few minutes, but all other items ("App data", "Call history", "Contacts" etc) have a message under them reading "Waiting to back up".

Under what conditions does the google backup start for these other items?

  • The phone is connected to Wi-Fi
  • The battery full battery
  • All OS updates are installed (or those that I've been prompted to)
  • No power-saving features are enabled
  • Tried attaching to recharger
  • Tried rebooting
  • Tried disabling/re-enabling backup

Is there something else I'm missing? Perhaps there is a setting somewhere to control when backup should be performed?

  • A common reason for that behavior is if you have activated the power save or data save mode. – Robert Oct 18 '18 at 17:51
  • @Robert Power savings are all turned off, but I hadn't thought about data savings...turns out they are also turned off. I'm a bit less panicked about this now though since I found that I can transfer data directly from this phone to my new android. Interestingly the new phone (Pixel) seems to have the same problem. – Chris Steinbach Oct 18 '18 at 20:11
2

TL;DR

In general it should be enough to leave your phone on charge, with Wi-Fi available overnight to trigger backup.

Unfortunately, bug reports from users indicate that google have had issues for some time with backups not being scheduled. We might guess that these issues have either not been prioritised, have been too difficult to fix, have been fixed and reoccured due to poor quality code or whatever.


Google cloud backup has been broken since 2016

My best guess is that my particular problem is a bug from 2016 that is still to be fixed (see this post). The answer in the linked post from a google employee says,

We have been investigating why some devices are rarely (or never) attempt to back up and have identified a bug within the backup scheduler. We're working on fix for upcoming Google Play Services release. We are not sure yet if this is the only issue, so will continue the investigation.

There are no further updates.

Meeting backup criteria (excluding the condition that bugs need to be fixed)

Regarding my question about what conditions will allow backup to continue, the same answer from the google employee provides some useful information:

Meeting backup criteria

Our main backup mechanism (K/V Backup) covers call history, device settings and a small subset of apps and will upload over any network connection and without requiring the phone to be idle and charging. However, our newer mechanism (Auto Backup for Apps) covers SMS and apps (~25% covered) is restricted to the device being on Wifi, idle and charging. The reason for that was that we theoretically can get up to 25MB of data to backup per app and that would not have a terribly positive effect on your data usage (for those who don't have the luxury of an unlimited data plan). We are working resolving this, in all likelihood by:

a) providing an option in settings to be more aggressive to backup, e.g. allowing it even when the device is not charging (but on Wifi)

b) allowing manual trigger of a backup in settings

c) providing warnings when backups haven't happened for a number of days

It seems that neither the bug fixes nor the proposed improvements have materialised, and so we might conclude that google gives cloud backup relatively low priority. Or I guess it could be that the backup code is horrific and takes an inordinate amount of time to modify and debug. Your guess is as good as mine.

On my new phone most items eventually got backed up (after about 24 hours). Now only Contacts are waiting for backup, so obviously something still isn't right, but for best results you could do worse than:

  • Make sure you're device is on Wi-Fi
  • Make sure that the charger is connected
  • Make sure your phone is idle

This last point is a little ambiguous. I imagine it to mean that you shouldn't be actively using your phone for some unspecified amount of time, but it's not clear to me whether stuff running in the background using CPU might affect the "idle" determination.

Without any better information available, you would imagine that leaving your phone on charge, with Wi-Fi available overnight ought to be enough to trigger backup.

Untested workaround

For those who feel sufficiently motivated, a workaround (one that I have not attempted myself) is to use adb to force a backup:

adb shell
bmgr run
bmgr backupnow --all
1

As I just discovered, on a Note 8, screen lock seems to disable backup - including greying out the "backup now" button. Disable screen locking and everything works. Re-enable locking, and no backup. Kind of strange.

0

I have a few suggestions, it can depend on a few different other phone factors but it's worth trying these;

1) turn the "back up to google drive" off, close the settings application and switch the device off then back on and re-enable the sync

2) if you are using a wifi try using a mobile network/phone hotspot as an alternate wifi source

3) i've had it before when the google account needs to be signed out and in again to re-authorise the connection

4) depending on the manufacturer/android version, sometimes each section needs to be turned on to enable sync

5) again depending on the version, some have security features when the time & date has to be updated and location turned on (I haven't come across this one personally)

i hope one of these helps!

protected by Community Jul 6 at 0:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.