1

Until recently I had multilingual typing enabled on my keyboard. It was possible to swipe in German and English at the same keyboard without changing languages. The spacebar had "English - German" written on it.

Somehow it got accidentally turned off. Maybe by some gesture on the spacebar?

Now I can't figure out how to turn that feature on again. The toggle used to turn it on in the keyboard settings is disabled and can't be turned on.

IMG:

The hint says that multiple languages have to be enabled. But where can that be done?

On the languages screen there are already two languages. Unfortunately they are also separate keyboards and I always have to switch with the globe button.

IMG:

  • I had the same issue with German (Austria) but it worked with German (Germany)!! – Anna Balázs-Csiki Nov 27 '18 at 10:00
1
+100

Likely reason is that the second language you want is not installed in language preferences

  • To do that go to System → Language and input → language → preference → add language (the one you want to be displayed on keyboard). If it is already there, remove and add ( You can tap and hold a language to change the order or remove language from the 3 dots menu on top right)

  • Now check as in first screenshot (of your question ) to see if multi lingual option is shown ( it should be). Enable the option and tick the language.

  • Long press or slide on space key to reveal option as shown and select the bilingual switch ( it is Telugu in first snapshot and TE in second ). Your keyboard should show as desired both languages. If it doesn't reboot and check 

enter image description here enter image description here

(Tap to enlarge)

Edit This didn't work for OP. Maybe the Gboard settings has Show Language switch key disabled (Language & input →Virtual keyboard →Gboard → Preferences →Show language switch key) . Enable that. Also see in this connection https://android.stackexchange.com/a/165509

Edit2 OP found the setting to be enabled but problem continues so - 1. Update Gboard if available 2. If not, go to settings and from app info of Gboard clear cache and see if that helps; next, clear data of app ;also disable and enable app

  • Unfortunately even though both languages are enabled in language preferences the option for enabling multilingual typing stays disabled. Removed the language, rebooted, re-added rebooted again always still the same. Any more ideas? Don't want to do a factory reset. – Florian Gutmann Oct 29 '18 at 15:40
  • 1
    Your answer provides a lot of good tips that could resolve similar issues and you tried very hard so I feel the bounty is justified. – Florian Gutmann Nov 4 '18 at 11:08
1

This seems to be an incompatibility or bug in newer versions of Gboard. The issue was solved for me by uninstalling all updates for Gboard.

Go to system preferences -> "apps and notifications" -> "all apps" -> "Gboard". Choose the 3 dot icon on top right and select "uninstall all updates".

This downgraded Gboard to version 7.5.12.211120321-release where it works. It doesn't work for me in the current Gboard stable release (version 7.6.13.215505041-release) nor in the current beta release (version 7.7.5.218156409-beta).

screenshot: uninstall all updates

1

I fixed this option by disabling Show emoji-switch key under Settings app > Languages & input > Virtual keyboard > GBoard > Preferences. Turn this off and the language icon will show up.

0

Based on the answer provided here gboard disable multilingual typing, do the following:

Go to Settings> Languages & input> Virtual keyboard> Gboard> Languages. Select a language for example English, then enable Multilingual typing. Also select the other language you want to appear on the keyboard (in my case French)

IMG:

  • I see @beeshyams has already posted the answer few minutes earlier than me – Reddy Lutonadio Oct 28 '18 at 14:49
  • No problem. Posted answer now explaining what needs to be done to enable seeing the multi lingual selection, which the OP was unable to choose as seen in the first screenshot – beeshyams Oct 29 '18 at 14:10
  • Unfortunately this option is grayed out and I can't enable it. – Florian Gutmann Oct 29 '18 at 15:42
0

I tried switching to "German (Germany)" from "German (Austria)" in "Settings > System > Languages & Input > Virtual keyboard > Gboard > Languages" and it worked! Gboard version 7.8.7.

language settings screenshot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.