I am trying to root my Xiaom mi a2 phone. But i am stuck on changing the active partition. When i enter "fastboot set_active b" it doesnt execute the command. Instead i get a list off all available commands which doesnt contain an option to change the active partition.

Console-Output enter image description here

I am following this tutorial: Tutorial

  • Please copy-and-paste the fastboot output instead of the screenshot. Screenshots aren't searchable, so they don't let people find your question.
    – Dan Hulme
    Commented Oct 27, 2018 at 14:24

3 Answers 3


First you need the actual fastboot, e.g. 1.4.3 (from link in the other answer). Then the correct command is:

fastboot --set-active=a


fastboot --set-active=b

In the help (fastboot help) you can read in fastboot version 28.0.3:

--slot <slot>                          Specify slot name to be used if the
                                       device supports slots. All operations
                                       on partitions that support slots will
                                       be done on the slot specified.
                                       'all' can be given to refer to all
                                       slots.'other' can be given to refer to 
                                       a non-current slot. If this flag is not
                                       used, slotted partitions will default
                                       to the current active slot.

-a, --set-active[=<slot>]              Sets the active slot. If no slot is
                                       provided, this will default to the
                                       value given by --slot. If slots are
                                       not supported, this does nothing.
                                       This will run after all non-reboot 

I tried a lot of things, nothing worked until i came across this: minimal-adb-and-fastboot-tool-for-windows

Now i was able to set the active partition and install the root. I got no errors and everything seemed fine but i still had no root access. I found this tutorial: guide-how-to-root-xiaomi-mi-a2-magisk and it worked for me.


Well, the fastboot you are using is outdated. You need to install the latest platform-tools from Android SDK which has the latest fastboot binaries.

This link will always give you the latest ADB & fastboot for Windows. For more information, here is how to install ADB and fastboot on Windows.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .