I recently formatted the sd-card as internal on my Android 7.1.2 (LineageOS 14.1). Now the camera app is showing an error message that it can't access the sd-card anymore. The error message is: "couldn't access sd card". I can't find the setting to change the storage folder of the camera app.

Does anybody have an idea how to fix that?


Meanwhile I found the solution. In the app settings I had to delete the app data and cache. That set the settings back to default which solved the issue.


Encountered the same issue on MIUI stable, solved by allowing the usage access permission for the camera app. (source)

edit: and you do it by opening the Settings app, enter passwords and security, privacy, special application access, usage access, choose the (native) camera app, and permit usage access.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.