2

I recently formatted the SD card as internal on my Android 7.1.2 (LineageOS 14.1). Now the camera app is showing an error message that it can't access the SD card anymore. The error message is: "Couldn't access SD card".

I can't find the setting to change the storage folder of the camera app.

Does anybody have an idea how to fix that?

0

3 Answers 3

4

Meanwhile, I found the solution. In the app settings, I had to delete the app data and cache. That set the settings back to default which solved the issue.

3

Encountered the same issue on MIUI 11.0.8.0 stable, solved by allowing the usage access permission for the camera app.

You do it by opening the Settings app - Passwords and security Privacy - Special application access - Usage access, choose the (native) camera app, and permit usage access.

Source: xiaomi.eu forum.

0
0

Another possible cause is if an old SD card had been used as the default location for the camera, and was since removed, and the system becomes determined to save to that specific SD card only (and wouldn't allow the location to be changed while it was unavailable).

This causes the same "Couldn't access SD card" error on taking photos in the camera, and causes images attached to messages to refuse to download, Bluetooth image shares to fail as "unsuccessful", etc, despite all these apps having correct storage permissions.

What fixed it was:

  • Going into Storage Manager
  • Selecting the old, absent SD card
  • Choosing to "Forget" it

As soon as the old SD card was forgotten, everything involving saving images started working again, and the setting to choose where to save images was no longer greyed out.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .