0

I use an ambient sound app through headphones while I sleep. This usually works quite well, except for the occasional night where i get woken up because Android has decided to drop the volume and display a message to the effect of "Listening at high volume for a long time can damage your hearing." I haven't managed to transcribe the exact wording yet because I'm usually grumpy and attempting to get back to sleep when it happens. I'm fairly certain that it can be displayed more than once per reboot cycle, as it was displayed last night despite my having used the phone this way numerous nights over the past couple weeks. (uptime currently shows 13 days.)

FWIW, I'm probably risking permanent hearing damage by doing this, but that seems a better bet than the certain negative effects (acuity, mood, cancer) of not getting a decent sleep.

Is there a way to disable this "feature", with or without root?

3

According to the article How to Automatically Disable the High Volume Warning without Root, the warning is implemented on devices due to European legislation which stipulates that:

all electronic devices capable of media playback sold after February 2013 must have a default output volume level of a maximum 85 dB. Users can choose to override the warning to increase the volume to a maximum of 100 dB, but in doing so the warning must re-appear after 20 hours of music playback.

(The warning should only appear if your device is using an European ROM)

It is possible to disable the warning by following the methods below:

  1. On rooted devices

If you have the Xposed framework installed, there are several modules (VolumeSteps+, NoSafeVolumeWarning, GravityBox, etc) that offer the option to disable the warning.

VolumeSteps+

GravityBox

  1. On non-rooted devices

The article above describes methods for disabling the warning using Tasker & AutoTools either at boot or periodically. It also has a link to download the Tasker's scripts.

In other forums, the app Hearing Saver is purported to work on non-rooted devices.

You can also go to Settings --> Apps --> Your_App --> Notifications --> enable Block Notifications

Note: I don't use Tasker that is why I have not included the process decribed in the article. However, those who are more knowledgeable with it can include the steps.

  • Cool, thanks. It sounded like there are issues with running Xposed on Samsung devices so I went the Tasker/AutoTools route. Just finished setting it up and there were a few awkwardly phrased questions and some caveats but hopefully it will work. I'll leave another reply here in a few days when results are in. – intuited Jan 21 at 8:44
0

On my Samsung Galaxy S9 I go into Settings, Sounds and vibration, Volume, and then click on the menu button on the top right-hand corner. Only option is Media volume limiter. Default is turned off and Custom volume limit is about 2/3 of the way but grayed out. Turn setting to On and you can now slide the volume all the way up to "Oh My God my ears are bleeding and my eardrums are about to burst but that's okay because now I can actually turn the volume all the way up while driving my car and connected to bluetooth without having to take my eyes off the road to look at my phone to press okay and possibly veer off my lane and into oncoming traffic where a huge semi delivering deadly snakes, spiders, and scorpions smashes into me and breaks just about everything in my body INCLUDING my ever loving eardrums, and all those deadly creatures get out and wreak havoc on anybody stopped on that stretch of roadway. And the truck driver hurt his finger". (If you didn't use Peter Griffin's voice reading this internal dialogue, shame on you. Go back and read it again using Peter Griffin's voice. I can't believe that I would have to tell you to use Peter Griffin's voice reading the above internal dialogue).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.