I'm using systemless Xposed Framework module (v90.2 beta 3) of Magisk Framework (v17.1) on a rooted OnePlus 6 running OxygenOS v5.1.8 (Android 8.1.0).

I'm having an issue with Xposed Framework and Play Store. Play Store crashes whenever I try to browse for an app, or install, or update an app. This problem has affected others users as well with no solution from rovo89 or topjohnwu as of yet.

I tried to identify the issue in logcat, just like the user here but miserably failed to understand what caused the crash.

The issue goes away so long as I keep disabled Xposed Framework from Xposed installer or from Magisk Manager.

How do I fix this problem?

1 Answer 1


The developer of GravityBox Xposed modules, C3C0, suggested to use official and original Xposed Framework (flashes system partition and breaks Safety Net). They confirmed it working alongside Play Store, but on Android 8.0 though.

Alternatively, one can try Aurora Store from F-Droid, as an alternative to Play Store and as an interim solution. It fetches apps' updates and new apps directly from Play Store. It also provides sufficient information regarding the app to be installed, such as What's new, permissions, and so on.

  • 2
    As long as you either have no apps using Play License Check or original Playstore does at least that without crashing, Yalp (or its fork Aurora) are fully sufficient (even better: cleaner, more straight-forward, no ads). Logged in with your G-account it can even update paid apps. I use it myself (as on my only device with GApps, Playstore refuses to update my apps saying "no network", but manages to update itself and PlayServices fine ¯_(ツ)_/¯).
    – Izzy
    Nov 3, 2018 at 12:11
  • 1
    @Izzy remember I was complaining about Aurora crashing occasionally, I updated and ever since then, I never encountered that problem again ( ͡° ͜ʖ ͡°). BTW I love Aurora UI and theming, besides no annoying stuff to self update unlike GPlay. Nov 5, 2018 at 17:25
  • I couldn't get Yalp to install despite multiple attempts /different mail IDs/no response from developer on bug report despite waiting for months. Finally, Aurora store, that can be downloaded from [Telegram link] (t.me/Aurora Support) worked
    – beeshyams
    Aug 26, 2020 at 9:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .