Note: I have researched this online, but none of the answers seem to work.

Currently, my honor 6X does not make any alarm sound. Obviously, this can lead to some predictable problems. I've made sure of the following:

  1. My volume, ringer, alarm, and calls are all turned to max.
  2. My regular volume works perfectly
  3. I am using the default clock app
  4. I deleted all my alarms and tried again, to no avail
  5. My phone was restarted (I do not want to do a factory restart unless that is the only possible solution)
  6. The alarm pops up, but has no sound
  7. I gave clock priority over other apps and gave it all the permissions possible
  8. I've tried different alarm sounds and reset it to the default
  9. I have turned off Bluetooth
  10. I have cleared all other apps
  11. I have turned off the Android given task manager
  12. I have no other clock apps
  13. Although, my phone is rooted, but for over a year now, and have only encountered this problem very recently, so I think I can cross that off my list.

I am completely lost now on what to do, I have basically tried everything possible. So how in the world can I get this to work? Any opinion or idea would be greatly appreciated

  • In alarm settings, please check whether you have enabled gradually increase volume to never. ( I am using Google clock)
    – Rahul Gopi
    Commented Nov 5, 2018 at 2:56
  • Have you disallowed notifications for the Clock app (including disallowing sound there)?
    – wbogacz
    Commented Nov 5, 2018 at 3:06
  • Also check if it is a protected app or whatever it is called now for those apps that switch off after screen is off
    – beeshyams
    Commented Nov 5, 2018 at 3:17
  • @wbogacz nope, all permissions granted
    – Gabe
    Commented Nov 5, 2018 at 3:18
  • 1
    @beeshyams I completely turned off the "protection app" for all apps.
    – Gabe
    Commented Nov 5, 2018 at 3:19

1 Answer 1


you can also try the following two methods.

  1. In the Settings - Smart Assist - Gesture setting, there is an alarm to turn the mute to see if it is caused by flipping the phone and causing the alarm to be muted.

  2. Wait for the new version and upgrade to the latest version

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .