1

I've a Nexus 5X on Oreo that has recently been making notification sounds when I wake it up from sleep. However, there are no visible notifications. I tried to look at logcat to see if there are any logs that coincide with the notification sounds, but it's too noisy. I did notice the following though, but I'm not sure if they're the culprit.

11-07 17:01:49.997  3460 17021 I WifiService: getConnectionInfo uid=10124
11-07 17:01:49.998  3460 17021 D WifiPermissionsUtil: Denied: no location permission
11-07 17:01:49.998  3460 17021 D WifiPermissionsUtil: Denied: The current config is not for an open network.
11-07 17:01:50.003  3460  4950 I WifiService: getConnectionInfo uid=10124
11-07 17:01:50.004  3460  4950 D WifiPermissionsUtil: Denied: no location permission
11-07 17:01:50.004  3460  4950 D WifiPermissionsUtil: Denied: The current config is not for an open network.
11-07 17:01:50.009  7249  7249 W Notification: Use of stream types is deprecated for operations other than volume control
11-07 17:01:50.009  7249  7249 W Notification: See the documentation of setSound() for what to use instead with android.media.AudioAttributes to qualify your playback use case
11-07 17:01:50.039 31569 31627 D Avrcp   : AudioManager Player: ID:23 -- type:android.media.SoundPool -- u/pid:10035/3869 -- state:idle -- attr:AudioAttributes: usage=USAGE_ASSISTANCE_SONIFICATION content=CONTENT_TYPE_SONIFICATION flags=0x0 tags= bundle=null
11-07 17:01:50.039 31569 31627 D Avrcp   : AudioManager Player: ID:3639 -- type:android.media.MediaPlayer -- u/pid:10035/3869 -- state:idle -- attr:AudioAttributes: usage=USAGE_NOTIFICATION content=CONTENT_TYPE_SONIFICATION flags=0x0 tags= bundle=null
11-07 17:01:50.039 31569 31627 D Avrcp   : AudioManager Player: ID:15 -- type:android.media.SoundPool -- u/pid:1000/3460 -- state:idle -- attr:AudioAttributes: usage=USAGE_ASSISTANCE_SONIFICATION content=CONTENT_TYPE_SONIFICATION flags=0x0 tags= bundle=null
11-07 17:01:50.039 31569 31627 D Avrcp   : AudioManager Player: ID:31 -- type:android.media.SoundPool -- u/pid:1027/6162 -- state:idle -- attr:AudioAttributes: usage=USAGE_NOTIFICATION content=CONTENT_TYPE_SONIFICATION flags=0x0 tags= bundle=null
11-07 17:01:50.039 31569 31627 D Avrcp   : AudioManager Player: ID:3631 -- type:android.media.MediaPlayer -- u/pid:10035/3869 -- state:started -- attr:AudioAttributes: usage=USAGE_NOTIFICATION content=CONTENT_TYPE_SONIFICATION flags=0x0 tags= bundle=null
11-07 17:01:50.039 31569 31627 D Avrcp   : AudioManager isPlaying: true
11-07 17:01:50.062  3114  3114 D NuPlayerDriver: NuPlayerDriver(0xf1414200) created, clientPid(3869)
11-07 17:01:50.082  3114 13299 D GenericSource: FileSource remote
11-07 17:01:50.094  3460 17021 I WifiService: getConnectionInfo uid=10124
11-07 17:01:50.094  3460 17021 D WifiPermissionsUtil: Denied: no location permission
11-07 17:01:50.094  3460 17021 D WifiPermissionsUtil: Denied: The current config is not for an open network.
11-07 17:01:50.097  3114 13298 D NuPlayerDriver: notifyListener_l(0xf1414200), (1, 0, 0, -1), loop setting(0, 0)
11-07 17:01:50.099  7249 13274 W Notification: Use of stream types is deprecated for operations other than volume control
11-07 17:01:50.099  7249 13274 W Notification: See the documentation of setSound() for what to use instead with android.media.AudioAttributes to qualify your playback use case
11-07 17:01:50.113  3460  3510 I ActivityManager: Start proc 13301:android.process.acore/u0a1 for content provider com.android.providers.contacts/.ContactsProvider2
11-07 17:01:50.116  3460  3460 E NotificationService: Muting recently noisy 0|info.kfsoft.android.TrafficIndicator|2131623986|null|10124
11-07 17:01:50.314 13301 13301 I ContactsPerf: VoicemailContentProvider.onCreate start
11-07 17:01:50.348 13301 13301 I ContactsPerf: VoicemailContentProvider.onCreate finish
11-07 17:01:50.401  3114 13289 I NuPlayerDecoder: [audio] saw output EOS
11-07 17:01:50.483 13301 13316 D ContactsDatabaseHelper: WAL enabled for contacts2.db: true
11-07 17:01:50.608 31569 31627 D Avrcp   : AudioManager Player: ID:23 -- type:android.media.SoundPool -- u/pid:10035/3869 -- state:idle -- attr:AudioAttributes: usage=USAGE_ASSISTANCE_SONIFICATION content=CONTENT_TYPE_SONIFICATION flags=0x0 tags= bundle=null
11-07 17:01:50.608 31569 31627 D Avrcp   : AudioManager Player: ID:3639 -- type:android.media.MediaPlayer -- u/pid:10035/3869 -- state:started -- attr:AudioAttributes: usage=USAGE_NOTIFICATION content=CONTENT_TYPE_SONIFICATION flags=0x0 tags= bundle=null
11-07 17:01:50.608 31569 31627 D Avrcp   : AudioManager isPlaying: true

PID=3460 is for system_server, and location setting is on(high accuracy), so I'm not sure why it's complaining of a permissions problem.

Tried dumpsys audio when I hear the sounds, and based on the timestamps, here are the relevant output:

Audio event log: focus commands as seen by MediaFocusControl
11-09 08:50:29:151 requestAudioFocus() from uid/pid 10035/3869 clientId=android.media.AudioManager@8aef0d8 callingPack=com.android.systemui req=3 flags=0x0 sdk=27
11-09 08:50:32:129 abandonAudioFocus() from uid/pid 10035/3869 clientId=android.media.AudioManager@8aef0d8

Audio event log: playback activity as reported through PlayerBase
11-09 08:50:29:120 new player piid:9887 uid/pid:10035/3869 type:android.media.MediaPlayer attr:AudioAttributes: usage=USAGE_UNKNOWN content=CONTENT_TYPE_UNKNOWN flags=0x0 tags= bundle=null
11-09 08:50:29:120 player piid:9887 new AudioAttributes:AudioAttributes: usage=USAGE_NOTIFICATION content=CONTENT_TYPE_SONIFICATION flags=0x0 tags= bundle=null
11-09 08:50:29:121 player piid:9887 has OP_PLAY_AUDIO:true in uid:10035
11-09 08:50:29:652 player piid:9887 state:started
11-09 08:50:29:654 releasing player piid:9879
11-09 08:50:30:156 new player piid:9895 uid/pid:10035/3869 type:android.media.MediaPlayer attr:AudioAttributes: usage=USAGE_UNKNOWN content=CONTENT_TYPE_UNKNOWN flags=0x0 tags= bundle=null
11-09 08:50:30:157 player piid:9895 new AudioAttributes:AudioAttributes: usage=USAGE_NOTIFICATION content=CONTENT_TYPE_SONIFICATION flags=0x0 tags= bundle=null
11-09 08:50:30:157 player piid:9895 has OP_PLAY_AUDIO:true in uid:10035
11-09 08:50:30:686 player piid:9895 state:started
11-09 08:50:30:688 releasing player piid:9887
11-09 08:50:32:129 player piid:9895 state:stopped

Audio event log: force use (logged before setForceUse() is executed)
11-09 08:50:32:130 setForceUse(FOR_MEDIA, FORCE_NO_BT_A2DP) due to setBluetoothA2dpOn(false) from u/pid:1000/3460

Any idea?

5
  • Did you, by any chance, enable screen unlocking sounds under Settings -> Sound & Vibration? If not, can you try "adb shell dumpsys audio" when the device makes that sound. You might be able to get something more from there. And there is dumpsys notification (though I don't think it is a notification, but still possible). There are also various media related services which ca help you find the problem and you can find them through adb shell 'dumpsys | less'. – Firelord Nov 7 '18 at 9:58
  • Screen unlocking sound was on, but that's not it since it's several sounds when I turn the screen on, not just one, and the sound starts once the screen is on, even on the lock screen. Anyway, I've disabled the screen unlocking sound and it still happens. Will take a look at the adb command soon. – user1118764 Nov 8 '18 at 11:00
  • Added dumpsys audio output, any ideas? – user1118764 Nov 9 '18 at 0:56
  • Do you have NFC enabled and an NFC card or something similar nearby. It is just a hunch but would you try disabling NFC and observe whether the issue persists? – Firelord Nov 9 '18 at 9:41
  • 1
    No, it's not the same notification sound as when an NFC card is nearby, I know that sound. Just realized that the notification sound comes on twice in quick succession whenever I turn my screen on. – user1118764 Nov 9 '18 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.