1

I just installed LineageOS 15.1 on my Galaxy Note 4 (SM910F) via TWRP, everything worked out nicely. Now I wanted to add the Gapps to the system in order to use the playstore. I downloaded the zip file from https://opengapps.org/ (ARM/Android 8.1/pico) and installed it with TWRP. After a reboot I keep getting messages that Google Play services repeatedly crashed, about every 10 seconds or so.

After some searching I found out that Google started blocking uncertified devices from using the service, but that there is a way to whitelist your "custom device" by submitting your Google Service Framework ID to Google. To get this GSF ID, I tried the commands given on the page (www.google.com/android/uncertified):

$ adb root
$ adb shell 'sqlite3 /data/data/com.google.android.gsf/databases/gservices.db "select * from main where name = \"android_id\";"'

But this did not work, no ID was found, neither via adb as above, nor in a local root shell directly on the phone. I then tried to read out the ID by using an app called "Device ID" (as described here), but this app also did not manage to get the GSF ID, the field was blank.

I already wiped the phone and retried the procedure with another gapps package (the "micro" variant), but I ran into the same problem.

Is there something I can do? I would love to use LineageOS, but unfortunately I still do need the Playstore and I really do not want to go back to the stock Android 6.

  • According to LineageOS Wiki, you have to flash gapps before rebooting into LOS for the first time. Have you done that? – Andrew T. Nov 17 '18 at 14:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.