1

I tried to update my Xiaomi Mi A2 to Android Pie since yesterday the Beta was Released. At first, I tried to install the official provided one, but after facing some errors, I installed the Treble version of the Android Pie Pixel Experience ROM.

It was working perfectly, but after installing Pixelify with Magisk, my WiFi stopped working, and I got the error MAC 02:00:00:00:00.

After trying some things with terminal apps and root, I opted for reinstalling the modem image, which I thought that could solve the problem, but instead, the phone didn't turn on, it kept on the Android One screen. So after waiting for some hours, I decided to format the phone and lose all of my data.

I formatted the system partition with fastboot erase system_a and fastboot erase system_b, but when trying to reinstall the PixelExperienceP ROM, I receive this error again and again:

fastboot flash system_a PixelExperienceP-arm64-ab.img
Sending sparse 'system_a' 1/5 (524284 KB)          FAILED (Error reading sparse file)
Finished. Total time: 24.591s

After that, I am not allowed to send any command to the phone until I restart de bootloader.

I have tried to install different ROMs, the stock one, other Android versions, but I get the same error on all of them.

Please, any ideas on how to solve my problem? I am really worried about having broken it. Thanks in advance.

0

3 Answers 3

2

I just solved it simply by trying and trying, changing cable, USB port, restarting computer...

0

Was facing the same problem with two devices (Google Pixel 4 and Samsung Galaxy S21 Ultra 5G (Exynos variant))

I've found that, in my case, for both the devices discussed, using the vendor provided flashing solutions (Odin 3.14.4 for Samsung and "flash-all.bat" script for Google) the procedure was stuck/hanging on some large transfer for both the devices (Odin was simply stuck at the "SYSTEM" phase (system.img) with the green progress bar halted/not moving while the Google script returned the infamous "FAILED (Error reading sparse file)" error message after "Sending sparse 'vendor_b 1/2 (524284 KB)").

I've tried leaving the devices connected for over 30 minutes, changing/swapping USB cables, upgrading/downgrading USB/Thunderbolt drivers, BIOS/UEFI to no avail.. I've retried the procedure many times with no different outcome..

I've then connected the devices to a USB 3.0 "A" port of my motherboard (Gigabyte Z170X-UD5 TH - fully updated Windows 10 1607 LTSB) instead of the USB/Thunderbolt enabled USB "C" port on the rear that I was previously using and to my surprise it worked flawlessy for both on the first try!

No idea if the Thunderbolt IC (or maybe its driver) was the culprit TBH but it seems so..

Just my experience

0

I was having FAILED (Error reading sparse file) issue when I was connecting the USB cable to the dock of my laptop.

Instead connecting the USB Type-A end directly to my laptop port helped me fix this problem. Be mindful of USB 3.0, USB Type C and USB 2.0 ports (try with all) and run your commands in command prompt in Administrator mode.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .