1

I have a OnePlus 6 running Android 9.0.2 rooted with Magisk, but no recovery. (I tried to install recovery before rooting it every way I could imagine, with no success.)

I had Lucky Patcher installed with patches applied to Android and to the Play Store, and everything was working fine. I recently updated Android from 8.1 to 9.0.2 and the patches were removed.

When I tried to patch it again, the play store disappeared and all the Google apps say that my device doesn't support Google Play Services.

I tried reinstalling the Play Store both from Lucky Patcher (original and mod versions) and from APKMirror, but whenever I try to open the app, it just says "Google Play Store keeps stopping".

And when I tried installing the Play Store as a system app with Lucky Patcher, it just wouldn't install.

I tried installing Google Play services from APKMirror, but the app just wouldn't install.

I even tried installing it using ADB, and I get this error:

Failed to install Downloads/ps.apk: 
Failure [INSTALL_FAILED_UPDATE_INCOMPATIBLE: 
Update to package com.google.android.gms doesn't support multi arch]

My question is, how can I get the Play Store and Google Play Services working again?

  • It might be worth looking into logcat to find out what happens (including errors) when you try to install Play Store and Play Services. – Firelord Nov 13 '18 at 17:02
0

Flashing the system again seemed to do the trick.

I followed this guide on xda

https://forum.xda-developers.com/oneplus-6/how-to/rom-stock-fastboot-roms-oneplus-6-t3796665

I just didn't flash the boot partitions, so I was able to keep my systemless root.

0

The real issue here is that Lucky Patcher breaks some Google Play Services when you apply inApp or Remove Google Ads patch. The fix here is to Roll back those changes you made to whatever app or service you applied the patch to. Then clear cache and dalvik, done.

0

I had similar issue, this was how I resolved mine:

  1. Open Magisk Manager
  2. Tap on Setting
  3. Enable Magisk Core

Reboot the device. After rebooting:

  1. Open Lucky Patcher
  2. Go to Toolbox
  3. Tap on Install modded Play Store
  4. Install the most recent version you see

NB: If it fails, enable Magisk core, after reboot, open Lucky Patcher > Rebuild and install > Lucky Patcher folder > Install app as system app.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.