2

Even though I have background data turned off, it is using incredibly high amounts of data to the point of being ridiculous. This is starting to cost me money as data is not unlimited in Canada. It's gotten to the point where I can't use data because if I turn it on Google just gobbles it all up. At one point, it was just full tilt downloading/uploading something I have no idea what it would be.

What is causing this and/or how can I turn off background usage for Google for real (obviously the toggle is a placebo)

Screenshots of data usage.

enter image description here enter image description here

  • Have you enabled Google Backup Cloud sync or do you sync the photos taken into the Google cloud? Have you enabled the Google assistant? – Robert Nov 13 '18 at 18:28
  • Interesting. I also disabled background data on all my apps. It takes a bit as you have to do each one manually. You can set data limits. Click the settings wheel in the top right corner in the first screenshot. Use that temporarily until you figure out what is causing data suck.. – fady Nov 13 '18 at 20:07
  • I have enabled google backup cloud sync, but I have had it enabled for years with no issues. Plus I have done nothing (that I can think of) to make it backup so many gigs - I haven't taken any pictures recently or received any files. Also, @fady, I already disabled background data. It is using background data even with the toggle to turn it off. It is ignoring the disable. – rjv Nov 13 '18 at 20:18
  • Are you using Google Launcher? I.e. left most swipe on the home screen brings you to the Google Assistant/Google Now interface with News cards. Check the main Settings (three dots in upper right of background) for the subsections on Discovery or Videos to see if anything looks amiss (Videos allowed on mobile networks perhaps?). – Morrison Chang Nov 14 '18 at 4:13
0

As an update to this: I never figured out the exact problem that caused this. Even after turning off features like google assistant it still continued to use an unusually high bandwidth. The eventual solution was rooting + custom kernel + custom ROMs. I don't have any issues now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.