I have the KDE Connect app in order to connect my Android phone (Moto Z2 Play) to my Ubuntu machine. With the upgrade to Android 8, this app has a new annoying behavior in that its icon is always in the Notification bar even when not connected. (If I pull down it says "Not connected to any device").

How can I get the icon to not appear in the Notification bar when the phone is not connected to anything?


3 Answers 3


You can choose to disable that notification by long pressing it and following what shows up there.

If you have a rooted device with Xposed framework, you can setup GravityBox and use its Notification blocked under Miscellaneous.

I, however, use MacroDroid to clear that notification (works only on Android 8.0 and above).

Trigger: Device events → Notification received → Select Application (s) → KDE Connect: Text content: Matches; Text: Not connected to any device; uncheck both the following options.

Actions: Notification →Clear Notifications → and then follow it as you did in Trigger.

Constraints: not required

Reboot the device, or restart the KDE Connect app, or simply run the macro by long-pressing it, followed by "Test actions".

That notification would no longer annoy you.


Excerpt taken from KDE Connect – New stuff 0x3:

Android Oreo introduced some restrictions in regard to apps running in the background. In the future in order to be able to run in the background KDE Connect needs to show a persistent notification.

To hide the notification you need to long-press it and switch it off. Other notifications from KDE Connect are unaffected by this.

  • Thanks for posting the official response, explaining why it behaves that way. +1
    – Firelord
    Commented Nov 19, 2018 at 16:00

On Android 9 Pie:

  • long press the notification
  • tap the information icon (blue "i" in a circle)
  • choose "Notifications"
  • uncheck "Persistent indicator"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .