1

I am getting a weird error, only in 1 of my phones. I am using Hockeyapp to distribute and test apps and it works fine in every other mobile device. In Oneplus 3 (A3003; Android 8.0.0; OxygenOS version 5.0.6) though, when I try to install an app from Hockeyapp I get the message that I need to enable 'Unknown sources'.

enter image description here

After I press APP SETTINGS I am taken to the unkown sources screen where Hockeyapp is selected, just like the image below.

IMG:

If I go back in Hockeyapp and try to install the app again, I still get the same error message. I tried to clean install Hockeyapp, change manually the unknown sources but nothing changes. I repeat that this only happens in this Oneplus device.

How can I solve this and install the app that I want from Hockeyapp?

Edit: I uninstalled Hockeyapp, installed it again and explicitly granted that permission. I still get the same error!

  • 1
    @beeshyams I am going to settings--> apps --> special access--> install unknown apps and I see that Hockeyapp is allowed. Are you suggesting to do a different thing that what I am describing? – papakias Nov 15 '18 at 9:55
  • This happened to be a problem to Solid Explorer in my OnePlus 6. I had to reinstall that application from scratch. Furthermore, I then granted that permission explicilty from Settings app instead of waiting for that app to ask. I don't know if this would work, but might be worth a try. – Firelord Nov 15 '18 at 10:09
  • 1
    @Firelord I tried that. Uninstalled Hockeyapp, installed it again and explicitly granted permission. I get the same error! – papakias Nov 15 '18 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.