1

The problem I'm having is mainly because all the websites that I've searched are next to impossible to follow. Either links are dead, or something horribly went wrong while translating, so I'm asking here.

I got an Alcatel One Touch pop C3. Not the "one touch 3" version, the 'C' is significant. Up until recently, it was impossible to load a different ROM on it, but it seems Lineage OS has released a version for the One Touch pop C3, so I wanted to give it a try.

with adb I was able to check that the bootloader is unlocked, with fastboot I tried to upload the TWRP image (TWRP-3.1.0.0-PopC3.img), but it won't work.

I can boot into fastboot with: adb reboot bootloader the device boots into a blank screen with => FASTBOOT mode...

I can list the device in question with fastboot devices

When I then do fastboot flashing unlock nothing happens, it just sits there.

Same thing happens when I do fastboot oem unlock.

When I tried to do fastboot flash recovery TWRP-3.1.0-0.PopC3.img, I get the following error: FAILED (remote: 'partition 'recovery' not support flash') (sic).

I was lead to believe, that the only way to successfully upload the file onto the phone, is via "SP Flash Tool" I have version v5.1824.00 installed which I believe is the latest one.

And that's where I'm pretty much stuck. I've installed the MT65xx USB VCOM drivers in a Windows VM, and that's pretty much it at this point.

I've also tried the Linux version of SP Flash Tool, but whenever I select the scatter loading file, and choose the TRWP image as recovery image, it just sits there and doesn't seem to do anything.

Do I need to boot into the fastboot bootloader, or something?

I can access the phone with adb and fastboot just fine, but I have no idea what that SP Flash Tool is doing, or if it is doing anything at all.

  • More detailed explanation of the process you tried and any messages from the failed process would improve your chances of getting an answer. As far as and and fastboot is. Concerned. How did you find out that your bootloader is unlocked with adb? Specifically what and command did you use? Where you in the bootloader when attempting to use fastboot? What fastboot command did you use to try to flash the recovery .img? What was the error message after the failed flash attempt? – Bo Lawson Nov 18 '18 at 9:16
  • @BoLawson alright, I amended my question. Pretty much all websites I found, claimed that MediaTek devices are generally unlocked, but I need to use that SP Flash Tool utility. Most of what I used just doesn't report anything. No error messages, etc. – polemon Nov 19 '18 at 0:30
  • Umm, I hate to break it to you but your bootloader is not unlocked. What adb command did you use that stated your bootloader was unlocked? I am interested to learn a new command. – Bo Lawson Nov 19 '18 at 1:09
  • 1
    Here are some other resources to learn about android along with android enthusiast. developer.android.com/studio/command-line/adb android.googlesource.com/platform/system/core/+/master/fastboot xda-developers.com – Bo Lawson Nov 19 '18 at 4:13
  • 1
    @Firelord yep, did exactly as stated there, and even got the "green ring" as they call it. Still, only boots into recovery shows "Erasing" for a split second and then shows me the recovery boot menu. Not sure what to do from here on out. – polemon Nov 23 '18 at 5:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.