1

I found an old Samsung Note 4 of mine which I flashed a few years ago (Lineage OS if memory serves me right) and which I wanted to reuse for my son.

It is unfortunately stuck in a boot loop:

  1. If booted normally, it goes though the "Samsung Galaxy Note 4" initial screen (black and white and then after some time there is a vibration and it reboots (in a loop)

  2. If booted with HomePowerVolume-Up, a blue `RECOVERY BOOTING...." appears together with the Samsung Note 4 screen above, then it reboots (in a loop)

  3. If booted with HomePowerVolume-Down it goes into Download Mode

I tried to flashed the latest TWRP (3.2.3) via Odin - no changes

What is the reason of such a boot loop? Is there a bootloader missing? (I found a bootlader and flashed it, the flash was successful but the problem is still the same)

My main goal is to boot into TWRP in order to wipe and reinstall a new Lineage OS

Note: Following up on the comments and answer, I wanted to clarify a few things:

  • the Note worked fine with Lineage OS installed
  • it was then left aside
  • it was then (not sure here) probably wiped via TWRP (the only thing sure is that at most the wipe functionality of TWRP was used, to do a factory reset). This is new information obtained after the one who had the phone in hands told exactly what she has done.
  • and then the problems started

This is to make it clear that it used to have a functional TWRP and a functional Lineage OS, then a wipe in TWRP occured, and then it cannot boot to TWRP (or Lineage)

  • It's highly possible that whatever method you used to install Lineage OS, not only triggered KNOX but has also overwritten the recovery with one designed for Lineage.... en.m.wikipedia.org/wiki/Samsung_Knox – Zillinium Nov 18 '18 at 22:34
  • Which variant of note 4 do you have? Looking through the official TWRP devices page there are a lot of note 4 variants. I do not mean this in a bad way but did you choose the correct TWRP file for your devices variant? Also did you: "Note many devices will replace your custom recovery automatically during first boot. To prevent this, use Google to find the proper key combo to enter recovery?" – Bo Lawson Nov 19 '18 at 14:38
  • @BoLawson: yes, I am aware of the various versions and chose the one specifically for my Note 4. I also clarified my question with a note at the end to specifically state that the phone worked under that configuration – WoJ Nov 19 '18 at 14:49
  • @Zillinium: Please see my update,a note at the end to specifically state that the phone worked under that configuration – WoJ Nov 19 '18 at 14:50
  • Which bootloader out that big list of bootloaders did you flash. It is important to know because the possible key to getting your device back is to flash Samsung factory firmware for your device. After that you can start to customize again. However, back to the bootloader version Samsung has a security feature call roll back protection fuse. That prevents flashing older firmware. The only thing the bootloader will allow to flash is firmware equal to or greater than what was on the device. – Bo Lawson Nov 19 '18 at 15:04
1

A boot loop can be caused by several reasons.
• Incompatible Boot and Recovery Image's.
• System Modifications
• File Permission Errors
• File Owner Errors
• Incorrect Formatting Of Files
• Knox And the last one i can think of is incorrect settings ( build.prop edits etc.. )

Yours seems to be the first one, or the last, Incompatible Recovery and Knox

Obviously you have had a working TWRP on that device before, so maybe you still have it from flashing the device years ago. Custom firmware like Lineage OS can also require it's own recovery image, that is dependent on the corresponding Kernel version.

If your Lineage OS installation was for an UPGRADED Android version like 4.4 to 5.1, then a new kernel for 5.1 will have overwritten your 4.4 kernel, and now that possible working TWRP is useless... This became a huge problem with people trying to downgrade device's, as it requires a factory level flash. Odin may have the ability the downgrade the devices boot image ( kernel ). and TWRP will work again, but Knox will stay triggered.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.