1

A friend of mine owns a ZTE T84, also known as the Telstra Tough Max. Unfortunately, he dropped the phone and cracked the screen which resulted in a non-responding touchscreen. The screen itself does work.

In the meantime, he has bought a new phone, but still wants to restore all his contacts from the old phone. So I promised him to take a look at it.

At first I checked his Gmail account with him to verify if all his contacts were backed up in that account. Unfortunately, that wasn't the case.

I am able to connect the phone to a PC and it is connected in PTP mode, which gives the possibility to copy all the photos but not the rest of the data stored in the phone.

Then I tried to use an OTG cable with a mouse connected to the device. Unfortunately, this didn't work either, because the phone doesn't function as a USB host.

After that, I ended up trying things via the recovery mode menu. I tried to access the device via ADB, but it doesn't show up in there. It looks like USB debugging is not enabled. I noticed, when choosing "Apply update from ADB", it does connect and shows up in adb devices as sideload. But I can't use adb shell from there on, only the sideload things.

When I choose the option "Reboot to bootloader" it gives me a black screen, but I noticed it popped up in device manager and fastboot list it in the devices. However, commands such as fastboot oem device-info don't work.

I also tried to wipe the cache partition in the hope that the usb-connection mode would change, but no luck with that.

I did a lot of Googling on this subject but, so far, no luck in finding the solution. Does anyone have an another idea of what I can try to gain control over the phone or at least restore his contacts?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.