1

I have a Wileyfox Swift and I have tried to install lineageos 15.1 by following the tutorial that can be found on the lineageos website. I have successfully installed adb, twrp and used it to install the zip file that contains the lineageos files.

After installing the zip file, the phone only boots on what I think is the fastboot screen (shown below) which gives me the following options:

  • Start : this will boot on the fastboot menu
  • Restart bootloader : this will boot on the fastboot menu
  • Recovery mode : this will start twrp
  • Power off : this will power off the phone

IMG:

Before installing the zip file, I have always checked the md5 file to make sure that there had not been a problem in the downloading process. I have tried to install crdroid but with the same result. I have also tried to install numerous version of lineagos but it does not work either. I have read online that this issue could be resolved by pressing for a long time on the volume down/power button but it didn’t work.

I have run out of idea and am wondering if anyone has any idea on how to resolve this issue?

migrated from security.stackexchange.com Nov 25 '18 at 15:55

This question came from our site for information security professionals.

  • Can you still boot into TWRP? Have you tried flashing your stock ROM from fastboot or from TWRP? – Firelord Nov 25 '18 at 18:01
  • What version of TWRP? Did you flash GAPPS and if so which one? The Bootloader version is on your device? Your devices bootloader screen it might state the version. Things to try: from the bootloader try these commands: fastboot reboot and then fastboot continue After that then the the best course of action is to flash the latest updated factory firmware image and start your custom Rom adventure again. Make sure that you flash the latest versions of things. Looking up your devices bootloader screen types. I found this gem. forum.xda-developers.com/… – Bo Lawson Nov 25 '18 at 19:09
  • Yes I can still use twrp and the version is 3.2.3. I flashed with GAPPS 8.1 pico. I tried the commands but fastboot can't see any devices. I have added a screenshot of the boot screen just in case it helps. Do you know how I can get the latest updated factory firmware image for the WileyFox Swift ? I did find old cyanogen mod rom (cyanogenupdatetracker.com/downloads) but I am not sure whether the link is genuine or not. – rkouere Nov 25 '18 at 21:43
  • They cite the official Wileyfox facebook: m.facebook.com/officialwileyfox/photos/… which also has a couple recovery zip downloads if you feel OEM is safer. I also found: forum.xda-developers.com/… which has a fastboot signed .zip. Try flashing the OEM zip first from the facebook page. Flashing the zip from wileyfox facebook page is a simpler process. If that does not work then try the fastboot signed zip from the xda link. If you need help I can explain the process with an answer. – Bo Lawson Nov 26 '18 at 19:09
  • Bo Lawson thank you very much indeed. I downloaded the rom from the official Wileyfox facebook, flashed the phone with it and re-did the install as per lineageos' website and I am now running the lineage os on my phone. Thanks again for your help. – rkouere Nov 28 '18 at 21:52
0

Old thread, but helped me fix my Wileyfox Swift as well.

I had the same issue - followed the TWRP route, erased and loaded the new image. On restart, the bootloader refused to load the system, just went round and round. Speculation on my part, but this might have been because some of us had to "patch" the 'fox bootloader to get the Android 7 update to load in the first place.

The links on the facebook page posted by Bo Lawson (thank you) are still active at the time of this post. I selected the "last" cyanogen release (see the Swift links, used ZNH2KAS7EB).

TWRP was already on, so I booted to recovery, used adp to push the file SW27-WF-CRACKLING-CM-13.1.5-ZNH2KAS7EB-RECOVERY.zip to /sdcard, then used TWRP to install it. This also replaced the "new" bootloader. The old Cyanogen image booted without issues, so just turned on USB debugging, then rebooted to bootloader.

Fastboot flash'd recovery with TWRP(3.2.3.0) again. Rebooted to recovery, then installed the replacement image (not Lineage, but e.Foundation's beta).

Works! ...and there was much rejoicing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.