When I'm playing audio over the A2DP data path to my car, the audio randomly will drop for half a second, then gradually comes back to full volume over perhaps a second of time. Speaking like a programmer, it's almost like something mutes the audio and then slides the volume up in a loop or something.

This problem did not occur on Bombaridier and the older Synergy Kernel, however it is happening with the newer kernel on Juggernaut v5, Paradox and SlickMOD, leading me to believe something in the kernel or newer system binaries might be causing it. This behavior happens in Pandora, Amazon MP3 and also the stock Music app.

Thinking that maybe a stray notification was the problem, I've tried disabling notifications in all of the apps I know of that notify, I've also tried switching the phone into vibrate and finally into full-silent, but it does not seem to affect the behavior. I have found no likely cause. I wish I was able to log alsa changes; maybe a script running constantly with something like:

while (true)
do cat /proc/alsa/some_alsa_status_entry >> /tmp/alsalog
sleep 1

Does anyone else have any ideas as to what this might be? It's really annoying!

  • Note: I also posted this on xda-developers; if someone provides the answer there first I will certainly post it here. Mar 8, 2012 at 20:57

1 Answer 1


I have a Galaxy 2s with this exact problem but I wonder if I might offer a suggestion as to what could potentially be the cause. I have no idea how to fix it but I’m hoping that what I share here might help someone who knows more about the way these things work to be able to solve the problem.

I have spent much of my career working in Broadcast Radio, the problem I have heard my phone have with audio dropouts followed by either a ramp up of volume back to the previous level OR an audio dropouts followed by a momentary slight speed shift in the audio playback (sounds a bit like an old cassette recorded when the batteries are starting to fail) many people would probably not notice the later problem because it is very subtle and you have to know what you’re listening for.

Anyway, I believe this could be caused because of a lack of word clock sync between the phone and the bluetooth receiver. I say this because there have been times when I have had digital audio devices such as CD players that are connected to an audio console or digital amplifier and with both devices free running in terms of their clock synchronisation exhibit almost exactly the same symptoms.

You see all digital audio devices require that the audio data be put into frames much the same as regular Ethernet data is transmitted around a network is put into frames, however in order for the audio to be at the correct pitch and speed generally speaking both the playback device (Phone) and the receiving device (Bluetooth receiver) need to have the same word clock, otherwise you end up with the two devices running freely and the audio frames wont by in sync. Depending on the Error correction implemented (sample rate conversion) on the receiver you can get really odd audio results. I think that this is what is causing this problem. Basically the Bluetooth receiver and the phone aren’t in sync so every few minutes you get a drop out.

It doesn’t seem to happen when you are talking on the phone which makes me think that when you have a call connection as this is bi-directional, the phone is probably synchronised to the Bluetooth device word clock. But when you are listing to music the connection is mono-directional so there is no sync. Anyway just a thought. Maybe someone out there who understands the way these units synchronise can figure out a fix.

  • I have a strong suspicion the problem is with the bluetooth kernel module. Are you running a custom rom that has the DarksideX kernel? May 10, 2012 at 14:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .