I have both a Sony and a Logitech device. Yesterday I opened the Market from my Google TV and it immediately began updating it to Google Play. It looked like was not updating for very long time but was showing me the "Updating" message so I though it may take time and left both devices on overnight. When I checked in the morning I think it was installed incorrectly on BOTH devices

So now when I open the Market on either device it shows me this:


When I try searching for something in the provided text box it shows this page:


I am not able to use the Market at all now. I tried to uninstall it but was unable to do so.

How can I fix this issue?

  • Have you tried doing a factory reset from settings?
    – Chahk
    Mar 9, 2012 at 17:10
  • market has begun "Updating" again when i tried to open it today .... i will update my answer if it works/or not this time .. thanks for the answer
    – Aamir
    Mar 10, 2012 at 8:26

1 Answer 1


"Doesn't work outside US currently. We are working on getting a fix out." ...

told me Les Vogel who is the Staff Developer Programs Engineer - GoogleTV

So i think we will have to wait.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .