I get an error "No connection: Couldn't connect to the server" when trying to assign my google account to the Google+ app on my 2.3.5 Android phone. Tried several times along the day today, any ideas what else I may try?

I have no connection problems with any of the other apps on the same phone at any time.


Check for a security notification under the notifications. I missed it at first on my tablet.

| improve this answer | |

I had the same problem... Go to Play Store and update your Google+ app and then try to sign in again. It worked for me.

| improve this answer | |

No connection, couldn't connect to the server. From deleting Google Play services. If you delete the Cache on some apps, you will have Sync problems. Shut the phone off, 30 seconds. Turn the phone back on. Main settings: Turn Airplane mode on 30 seconds. Turn Airplane mode off. This should work. Last resort: Factory Reset. Located on phone menu settings.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.