1

I'm in dire straits. I have been using an unofficial LineageOS port for almost 2 years. I was going to give the phone away to my buddy as a Christmas gift, he only has an S3 mini with a shattered glass. Literally minutes after I paid for my new (used) phone, my S4 screen went completely pink at the same moment I received a message. The vibration from the message notification turned into a loop while the pink screen stayed on. I used to get the pink screen every now and then, but usually only for a fraction of a second. After that I only had to lock and unlock the screen to continue operation. Several other users have reported this minor bug.

After removing the battery, the phone would go into a boot loop. I re-started several times and it did boot up again once after several minutes of a black screen, but before I could do anything, like save my current day's data, it went pink again. The worst part is I couldn't even enter recovery for whatever reason, it would just re-boot but never go beyond the Samsung splash screen. Download mode did work in the beginning so I used the chance to flash several other TWRP ROMs, and did manage to boot to recovery once, again only seconds before the screen went pink again.

After these experiences, it behaved like the battery would be drained rapidly. The amount of time that the splash screen would show up decreased from the full time to only a fraction of a second. Likewise when I plugged in the charger, it would only flash the charging logo before going off again. After several re-tries, it wouldn't even vibrate anymore when connecting the charger.

I thought my S4 had died on me, and that I had watched it fade away slowly and painfully, until after several hours of charging, it turned on all of a sudden, but only for the Samsung splash screen. After that it seemed completely dead again. Pretty random behavior, but at least a little sign of life.

I already tried my older battery, which let me power it on for a while, before eventually reproducing the same behavior until it also wouldn't turn on again. Luckily, I have now gotten a third battery (all three original Samsung), and with that it would immediately power on again, and go into a boot loop after the Samsung splash screen. However this time I could enter recovery on the first try, so I tried:

  • Wipe Cache/Dalvik
  • Flash latest LOS from first post
  • Wipe System/Cache/Dalvik
  • Flash latest LOS from first post

In that order. The first options resulted in the same boot loop as before, while the last options finally showed the LOS boot screen for a couple of seconds, until the screen turned pink again. I had to remove the battery to start over.

So I finally gave up on LOS and tried flashing Stock with Odin, as long as it would let me enter download mode. All went normal, but now after the Samsung splash screen it simply stays black. Tried again, now the screen only stays black a couple of seconds until it reboots. How can that be after a Stock ROM flash?

So I let the battery fully charge. For the first time since the start of the problems, the LED would turn on, first red then green. I pressed the power button and lo and behold, the Samsung boot animation (after the splash screen) showed up. I was hopeful for several minutes (normal after Stock flash) until it went back to boot loop.

I couldn't even factory reset because the stock recovery Android icon would only show up for a couple of seconds before the boot loop resumed. So I flashed latest TWRP again, and started flashing LOS when the after several seconds the screen turned pink again. Tried flashing stock with Odin once more, phone shut off midway through. I have just completed my third stock flash, and it went straight to boot loop. However this time it would let me enter stock recovery and I did a complete factory reset + wiped the cache partition. Still stuck at boot loop.

I'm at my wit's end.

Edit: Tried it with a stock ROM from a different carrier, same result.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.