1

I have a Nexus 7 (2013), 32GB, WiFi-only, that won't boot. I had been using it daily, until I woke up one morning to a boot loop. It was plugged in all night, but was at about half battery when I woke up (after turning it off). After what feels like a longer than normal boot animation, it goes to the "optimizing apps" window. It completes that and goes to "starting apps", but then restarts.

It is running 6.0.1, unmodified with locked bootloader. USB debugging is on

I am able to boot into recovery and tried clearing the cache.

Is there any way to recover without wiping my data?

fastboot getvar all:

(bootloader)  version-bootloader: FLO-04.08
(bootloader)  version-baseband: none
(bootloader)  version-hardware: rev_e
(bootloader)  version-cdma: N/A
(bootloader)  variant: flo 32G
(bootloader)  serialno: 09ace413
(bootloader)  product: flo
(bootloader)  secure_boot: enabled
(bootloader)  lock_state: locked
(bootloader)  project: flo
(bootloader)  off-mode-charge: yes
(bootloader)  uart-on: no
(bootloader)  partition-type:bootloader: emmc
(bootloader)  partition-size:bootloader: 0x0000000000aee000
(bootloader)  partition-type:recovery: emmc
(bootloader)  partition-size:recovery: 0x0000000000a00000
(bootloader)  partition-type:boot: emmc
(bootloader)  partition-size:boot: 0x0000000001000000
(bootloader)  partition-type:system: ext4
(bootloader)  partition-size:system: 0x0000000034800000
(bootloader)  partition-type:cache: ext4
(bootloader)  partition-size:cache: 0x0000000023000000
(bootloader)  partition-type:userdata: ext4
(bootloader)  partition-size:userdata: 0x00000006b7ffbe00
all:
finished. total time: 0.114s

fastboot oem gpt-info:

...
(bootloader)    partition[1].name = radio
(bootloader)    partition[1].first_lba = 131072
(bootloader)    partition[1].last_lba = 306143
(bootloader)    partition[1].size 87536 KB
(bootloader)    partition[2].name = modemst1
(bootloader)    partition[2].first_lba = 393216
(bootloader)    partition[2].last_lba = 399359
(bootloader)    partition[2].size 3072 KB
(bootloader)    partition[3].name = modemst2
(bootloader)    partition[3].first_lba = 399360
(bootloader)    partition[3].last_lba = 405503
(bootloader)    partition[3].size 3072 KB
(bootloader)    partition[4].name = persist
(bootloader)    partition[4].first_lba = 524288
(bootloader)    partition[4].last_lba = 554287
(bootloader)    partition[4].size 15000 KB
(bootloader)    partition[5].name = m9kefs1
(bootloader)    partition[5].first_lba = 655360
(bootloader)    partition[5].last_lba = 656919
(bootloader)    partition[5].size 780 KB
(bootloader)    partition[6].name = m9kefs2
(bootloader)    partition[6].first_lba = 656920
(bootloader)    partition[6].last_lba = 658479
(bootloader)    partition[6].size 780 KB
(bootloader)    partition[7].name = m9kefs3
(bootloader)    partition[7].first_lba = 786432
(bootloader)    partition[7].last_lba = 787991
(bootloader)    partition[7].size 780 KB
(bootloader)    partition[8].name = fsg
(bootloader)    partition[8].first_lba = 787992
(bootloader)    partition[8].last_lba = 794135
(bootloader)    partition[8].size 3072 KB
(bootloader)    partition[9].name = sbl1
(bootloader)    partition[9].first_lba = 917504
(bootloader)    partition[9].last_lba = 920503
(bootloader)    partition[9].size 1500 KB
(bootloader)    partition[10].name = sbl2
(bootloader)    partition[10].first_lba = 920504
(bootloader)    partition[10].last_lba = 923503
(bootloader)    partition[10].size 1500 KB
(bootloader)    partition[11].name = sbl3
(bootloader)    partition[11].first_lba = 923504
(bootloader)    partition[11].last_lba = 927599
(bootloader)    partition[11].size 2048 KB
(bootloader)    partition[12].name = aboot
(bootloader)    partition[12].first_lba = 927600
(bootloader)    partition[12].last_lba = 937839
(bootloader)    partition[12].size 5120 KB
(bootloader)    partition[13].name = rpm
(bootloader)    partition[13].first_lba = 937840
(bootloader)    partition[13].last_lba = 938863
(bootloader)    partition[13].size 512 KB
(bootloader)    partition[14].name = boot
(bootloader)    partition[14].first_lba = 1048576
(bootloader)    partition[14].last_lba = 1081343
(bootloader)    partition[14].size 16384 KB
(bootloader)    partition[15].name = tz
(bootloader)    partition[15].first_lba = 1179648
(bootloader)    partition[15].last_lba = 1180671
(bootloader)    partition[15].size 512 KB
(bootloader)    partition[16].name = pad
(bootloader)    partition[16].first_lba = 1180672
(bootloader)    partition[16].last_lba = 1180673
(bootloader)    partition[16].size 1 KB
(bootloader)    partition[17].name = sbl2b
(bootloader)    partition[17].first_lba = 1180674
(bootloader)    partition[17].last_lba = 1183673
(bootloader)    partition[17].size 1500 KB
(bootloader)    partition[18].name = sbl3b
(bootloader)    partition[18].first_lba = 1183674
(bootloader)    partition[18].last_lba = 1187769
(bootloader)    partition[18].size 2048 KB
(bootloader)    partition[19].name = abootb
(bootloader)    partition[19].first_lba = 1187770
(bootloader)    partition[19].last_lba = 1198009
(bootloader)    partition[19].size 5120 KB
(bootloader)    partition[20].name = rpmb
(bootloader)    partition[20].first_lba = 1198010
(bootloader)    partition[20].last_lba = 1199033
(bootloader)    partition[20].size 512 KB
(bootloader)    partition[21].name = tzb
(bootloader)    partition[21].first_lba = 1199034
(bootloader)    partition[21].last_lba = 1200057
(bootloader)    partition[21].size 512 KB
(bootloader)    partition[22].name = system
(bootloader)    partition[22].first_lba = 1310720
(bootloader)    partition[22].last_lba = 3031039
(bootloader)    partition[22].size 860160 KB
(bootloader)    partition[23].name = cache
(bootloader)    partition[23].first_lba = 3031040
(bootloader)    partition[23].last_lba = 4177919
(bootloader)    partition[23].size 573440 KB
(bootloader)    partition[24].name = misc
(bootloader)    partition[24].first_lba = 4194304
(bootloader)    partition[24].last_lba = 4196351
(bootloader)    partition[24].size 1024 KB
(bootloader)    partition[25].name = recovery
(bootloader)    partition[25].first_lba = 4325376
(bootloader)    partition[25].last_lba = 4345855
(bootloader)    partition[25].size 10240 KB
(bootloader)    partition[26].name = DDR
(bootloader)    partition[26].first_lba = 4456448
(bootloader)    partition[26].last_lba = 4456463
(bootloader)    partition[26].size 8 KB
(bootloader)    partition[27].name = ssd
(bootloader)    partition[27].first_lba = 4456464
(bootloader)    partition[27].last_lba = 4456479
(bootloader)    partition[27].size 8 KB
(bootloader)    partition[28].name = m9kefsc
(bootloader)    partition[28].first_lba = 4456480
(bootloader)    partition[28].last_lba = 4456481
(bootloader)    partition[28].size 1 KB
(bootloader)    partition[29].name = metadata
(bootloader)    partition[29].first_lba = 4587520
(bootloader)    partition[29].last_lba = 4587583
(bootloader)    partition[29].size 32 KB
(bootloader)    partition[30].name = userdata
(bootloader)    partition[30].first_lba = 4718592
(bootloader)    partition[30].last_lba = 61079518
(bootloader)    partition[30].size 28180463 KB
(bootloader)    partition[31].name =
(bootloader)    partition[31].first_lba = 0
(bootloader)    partition[31].last_lba = 0
(bootloader)    partition[31].size 0 KB
(bootloader)    partition[32].name =
(bootloader)    partition[32].first_lba = 0
(bootloader)    partition[32].last_lba = 0
(bootloader)    partition[32].size 0 KB
(bootloader)    partition[33].name =
(bootloader)    partition[33].first_lba = 0
(bootloader)    partition[33].last_lba = 0
(bootloader)    partition[33].size 0 KB
(bootloader)    partition[34].name =
(bootloader)    partition[34].first_lba = 0
(bootloader)    partition[34].last_lba = 0
(bootloader)    partition[34].size 0 KB
(bootloader)    partition[35].name =
(bootloader)    partition[35].first_lba = 0
(bootloader)    partition[35].last_lba = 0
(bootloader)    partition[35].size 0 KB
(bootloader)    partition[36].name =
(bootloader)    partition[36].first_lba = 0
(bootloader)    partition[36].last_lba = 0
(bootloader)    partition[36].size 0 KB
(bootloader)    partition[37].name =
(bootloader)    partition[37].first_lba = 0
(bootloader)    partition[37].last_lba = 0
(bootloader)    partition[37].size 0 KB
OKAY [  0.627s]
finished. total time: 0.628s

fastboot format cache:

Creating filesystem with parameters:
    Size: 587202560
    Block size: 4096
    Blocks per group: 32768
    Inodes per group: 7168
    Inode size: 256
    Journal blocks: 2240
    Label:
    Blocks: 143360
    Block groups: 5
    Reserved block group size: 39
Created filesystem with 11/35840 inodes and 4616/143360 blocks
erasing 'cache'...
OKAY [  0.403s]
sending 'cache' (10984 KB)...
FAILED (remote: Bootloader is locked.)
  • I don't know how well it would work, or if at all work, but you can direct your search to Qualcomm flash tool. It employs flashing at a level lower than fastboot. With this, you may be able to flash twrp recovery in the recovery partition without unlocking bootloader and auto-wiping data. After that, boot into TWRP and salvage your data. But, I'm short on time, so I can't do much of a search for your case. :-) Search for cases where a Nexus 7 2013 is hard bricked, only gives vibration but no screen or anything. Such cases might lead you to a solution. Be careful in blindly following a step. – Firelord Nov 30 '18 at 12:58
1

This is the strangest coincidence. I had exactly the same thing 2 days ago with exactly the same tablet (nexus 7 2013 wifi, running android 6.0.1 build MOB30X, unrooted, bootloader locked, USB debugging probably on): plugged in all night, was turned off in the morning, tried to boot but only 5 flashes of the led light (aka battery empty), charged it during the day, booted in the evening, took a long time with the four coloured dots (2 minutes at least, up to 10 and more on other reboots), then "optimizing apps" followed by "starting apps", and then a reboot... Exactly the same, I let it run for an hour, only the time with the "four coloured dots" varied...

Fastboot/recovery accessible. I tried wiping the cache, reboot with or without power supply, even opened the thing to check for lose contacts - didn't work. I tried this https://drive.google.com/file/d/0Bz6x7k-VkpUJQWFtYzFHNTFzUEE/view (can't remember where I found it), did the whole procedure but still the same "bootloop". If it is an app that causes the issue: I did not find a way to boot in safe mode or any other way to start without apps. I also downloaded Nexus Root Toolkit 2.1.9 - didn't work.

I just did a factory reset...took several minutes to boot after wiping data, but I have a clean tablet now. Boots in less than 30 seconds. Hooray? Only lost too many hours of game progress, photos were backed up recently, otherwise no other important data.

I hope you find a way to recover your data, but I just spend a whole day looking for a solution and found none. Too late now. Good luck!

  • I guess it could be a system app update that caused it, my phone had updates for Gmail, Contacts, and Maps. – Malik Drako Nov 29 '18 at 21:15
  • I ended up wiping my tablet too. I did make sure to unlock the bootloader and install a custom recovery before putting anything on it again so I have a way to back things up if this happens again – Malik Drako Jan 5 at 0:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.