12

I am using Android Lollipop mobile. I have uninstalled preinstalled Youtube app updates. Now I tried to update the app from Play Store. It is giving the error "Can't install app" with error code 910.

I have tried the following steps:

  1. Deleted Play Store app's cache and data.
  2. Deleted Download manager app's cache and data
  3. Deleted Youtube app's cache and data.
  4. Restarted phone.

And tried again, still same error occurred. How do I fix this?

IMG:

  • 1
    A pity they can't give details in addition to the number. The actions you performed are what's recommended for the 910 in other places. Have you tried following that link? // One page I found names the 910 "Application Authorization". If that's the case, maybe signing out of your Google account and then signing back in might do the trick. – Izzy Nov 29 '18 at 11:54
  • May be data connection is giving issue, try with WiFi connection once for your updation procedure. – Jeel Vankhede Nov 29 '18 at 15:53
  • Try to remove your Google account, then add it again. Clear Google play Data, and maybe check the date and time. Never had this kind of issue but there was an error once in my phone and it was solved by clearing Play Store data. – Muhammad Hamza Dec 2 '18 at 4:46
  • 1
    Having the same problem right now. I tried downloading an external YouTube APK, it did not work. I tried uninstalling and reinstalling via adb and it did not work either (Error 941). I tried removing the SD and updating, and reinserting and updating, neither did that work. – Peter Johnmeyer Dec 31 '18 at 8:26
  • Cleared Play Store cache and it works for me. Go to Settings/Apps/Google Play Store/Storage/Clear cache. – Hp93 Mar 4 at 16:17
3

I had the same problem after trying to upgrade my Snapchat app to the alpha version following a tutorial on the XDA developers forum. After finishing the tutorial, the app wouldn't uninstall, run, or reinstall properly. The solution (for me) was to uninstall the broken app using ADB.

  1. Install adb (if you haven't already).
  2. Enable developer mode on your phone (if you haven't already).
  3. Type adb devices into the terminal / command line.
  4. Tap 'yes' on the authorization prompt on your phone (if you haven't already authorized).
  5. Type adb uninstall <insert package name here> to uninstall the broken app.
  6. You can now reinstall the app from the Play store or wherever you got it from.
  • 1
    This is my kind of way of solving that issue. If i cant snatch a more superior version of the app than the version in store – Thally Ace Jan 13 at 17:20
3

I had been getting error 910 for days. I finally managed to solve the problem using the following steps:

I "ejected" the SD card via settings, device, storage. I didn’t physically need to remove the card from the phone.

(Android 6.0.1..... Blackberry Priv.)

  • It worked! finally! – Omid Jan 11 at 18:54
2

Unfortunatly none of these solutions worked for me. So I have downloaded latest Youtube apk from third party site and installed successfully. App is working fine. But in Play store it is still showing my earlier version app and asking to update. I guess hereafter every time I need to update from apk only.

2

Go to storage setting and set default storage setting to “Phone memory” or “Let the device decide”.

(Error 910 happens due to sd card set as a default storage.)

  • This worked for me. – Ankit Seth Dec 10 '18 at 18:55
  • For the record, Error 910 doesn't have anything to do with the SD card being the default storage. It refers to the inability to install an APK due to various reasons, mostly related with the FileSystem, but can happen if you attempt to install an app, whose APK is previously installed (whether an old version or a different signature is irrelevant). – Martin Marconcini May 22 at 11:16
1

I had this problem with a Blackberry Priv with Android 6.01. What worked for me was:

  1. Go to Settings → Personal → Security → Device administrators, disable the “Google Pay” administrator, and enable the “Blackberry Launcher” administrator.
  2. Go to Settings → Device → Users, and select Guest.
  3. Go to Settings → Device → Users, and select Myself - and log back in.
  4. Return to Google Play → My apps and games, and install.

This was done after a reboot and two previous installation attempts. The app that wouldn’t update was “Google”.

0

In my case it was the Wish app. It would download, then pop up with that exact error.

I moved it from my external SD card back to internal storage. I updated it, then went to move it back to external SD card, but it said I had no space. I know for a fact I do (I had a 512 GB SD card, so plenty of room). I ended up turning phone off for a few minutes then back on, and it moved just fine. So if it's moved to external SD card, maybe that's it.

0

I was having the exact same issue! I just solved it by removing the sd card from my device. I don't know if the error will return after I put it back, but I was able to install apps.

protected by Community Dec 10 '18 at 20:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.