4

I have a Xiaomi Redmi 4A and I used to often transfer files between it and my Windows 10 laptop PC over USB cable.

When I plugged in the cable the phone it used to prompt me to choose between USB charging and USB file transfer.

I didn't use this feature for months and a couple of weeks ago the phone told me MIUI 10 was available so I upgraded it it seemed very nice.

Today I want to transfer some files from the phone to the PC and now when I plug in the cable, the screen comes on and both devices beep but I am not offered to choose between charging and transfer. The phone does not show up in Windows explorer to browse files.

The phone does show on the computer as a connected USB device. But I can't find any settings or options on the phone or the computer to browse or transfer files on the phone.

Has this feature been removed in MIUI 10 or is it hidden behind non-obvious settings? Or am I missing something very simple?


  • I have tried two different USB cables. At least one of the cables caused my feature phone to show up as a USB storage device or MTP advice.
  • I have tried rebooting the phone and the behaviour afterwards is identical.
2

Though I was pretty sure I'd transferred files with at least one of the USB cables I tried around the time I posted this question, I tried a third cable at work tonight and the file transfer option now appeared!

So unless it was a coincidence, it seems it was due to a USB cable that was designed only for charging and lacked the wiring for file transfers!

1

On Windows PCs and other desktop PCs:

  • try to use a different USB port, often rear ports have more power than the front ports which is sometimes needed by some devices
  • use an USB 2.0 port if your mainboard supports both ports next to a possible type c port.
  • make sure ADB and your device drivers are installed (you can find your device drivers on your phone manufacturers homepage.

On your mobile device:

  • go to settings -> "my device" (or similar) and tap on your build number multiple times
  • go to "advanced" -> "developer settings" and check if "Select USB Configuration:" is set to MTP for file transfer or PTP for your Android to play a digital camera storage.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.