1

I have a Pixel which is running Android 9 and I have a computer running El Capitan with Android File Transfer. Under "Use USB for…", I have "PTP" selected. Android File Transfer only shows the folders Pictures and DCIM and no other folders or files at that directory depth. Prior to selecting "PTP", I was on "No data transfer" and Android File Transfer told me I needed to select "File Transfer" or "MTP" for it to work. "File Transfer" mode results in Android File Transfer saying I need to reboot or disconnect my phone; this didn't work.

I've already searched for an answer to this and these are things that don't work:

  • I cannot select "MTP". There is no such mode, only "PTP".
  • There is no Settings > Apps > All applications > Media storage under which I can select Clear data.

I also can't even get a USB drive, connected to my Pixel using a micro USB to USB-C adapter, to show up in Android so I can transfer devices to and from it.

How do I fix this nightmare?

Update #1: I was able to fix this the first time by updating AFT. Several weeks later, I now have the same problem again. I've already updated AFT once more.

  • Enable developer option (by tapping build version in settings 7 times) and see if you have something like "select USB configuration" and in that choose MTP or other options. I don't have Pie running to check – beeshyams Dec 1 '18 at 7:36
  • @beeshyams I said there is no "MTP" option. – Melab Dec 1 '18 at 16:49
  • 1
    File Transfer is the option in Settings->Connected devices->USB and 'USB Controlled by - This Device' that works for me running Mac OS High Sierra with Android File Transfer (Version 1.0.11 (1.0.442.1500)). I can see multiple directories on a Pixel 2 with Android 9.0. When you say "reboot", have you tried rebooting both the phone and laptop? – Morrison Chang Dec 1 '18 at 19:34
  • @MorrisonChang No, I have tried rebooting the computer. It doesn't mean that and there is no need to. – Melab Dec 3 '18 at 18:34
  • @beeshyams There should be no need to. – Melab Dec 3 '18 at 18:39
0

I have some tips for you to get it working because Android 9 lacks the notification popup which asks to select between modes(File Transfer, MIDI, PTP, No data transfer, Charging,etc.) when you plug your phone to your computer via USB.

You can try the following things:

  1. Enable Developer Options.
  2. Enable USB debugging.
  3. Try changing USB port on your computer in which you are plugging your phone.
  4. Make sure you are using data cable and not the charging cable.
  5. Go to USB Default Configuration in Developer Options, there you will see different modes(File Transfer, MIDI, PTP, No data transfer, Charging,etc.) to choose from.
  6. After selecting 'File Transfer', unplug and plug your phone again.

For more details, visit the link below: https://youtu.be/l8jP8YxDL5w

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.