I am trying to root my Samsung A7(2017). I have installed twrp to my phone but when I open it to install SuperSU it writes Internal Storage(0 MB) therefore I can not access to SuperSU. I am searching this topic for hours and tried many ways but couldn't solve it. How can I fix this problem?


Sounds like your internal storage is encrypted.

In order to fix this

  1. boot into the Android OS.

  2. Set a screen lock PIN or password.

  3. Make sure you save it as requiring password on startup.

  4. Then bootup into TWRP and it should ask you for your password to decrypt.

  5. Put in the correct password

Your files should show up again.

  • I did that several times and it did not work. While trying to solve it I mistakenly deleted the OS. I am trying to fix that for hours. I have downloaded os from sammobile for a7(2017) but when I try to upload it from odin to my phone it stuck at setup connection and after some time it says fail and gives the following error on the phone SW REV. CHECK FAIL(BOOTLOADER) DEVICE: 6, BINARY: 5. – E.Canberk Dec 7 '18 at 9:58
  • TWRP 3.2-3.0. I have downloaded the latest version of android for my device and I can't downgrade if I waned to because there is no OS in the systerm. – E.Canberk Dec 7 '18 at 10:32
  • Thats the exact thing I am trying to do but I get this error SW REV. CHECK FAIL(BOOTLOADER) DEVICE: 6, BINARY: 5 on phone and odin says FAIL. – E.Canberk Dec 7 '18 at 10:47
  • The first link was the one I downloaded but now I am downloading the second link. sammobile.com/firmwares/galaxy-a7-2017/SM-A720F/TUR/download/… sammobile.com/firmwares/galaxy-a7-2017/SM-A720F/TUR/download/… – E.Canberk Dec 7 '18 at 11:00
  • The the second link you should work. A720FXXU6CRJ7 device 6 binary 6. The first will not work A720FXXU5CRH3 device 6 binary 5 – Bo Lawson Dec 7 '18 at 11:04

If the first solution does not open your encryption door to show your internal storage within TWRP. There is another option that should correct your internal storage issue. Format the Data, however it will cause the loss of your UserData. If the data is important to you, make a backup the /data partition. There are two simple approaches: one is through fastboot, the other is within TWRP. Since your device is a Samsung that negates the fastboot option.

  1. Boot your device into TWRP recovery.
  2. Within TWRP select the wipe option.


  1. Select Format Data, and then slide the bar over on the bottom of the screen


This will format the encrypted /data partition erasing the encryption. A new un-encrypted /data partition will be created, thus making your internal storage visible.

  • Thank you for your help. I have fixed the issue and I can use my phone once again. I have also rooted it with magisk. It shows that it is rooted on root checker but when I try to run an app which requires root, the app doesn't respond, work, or sometimes even the whole phone crashes. I have doubt that perhaps I haven't downloaded the root right therefore I deleted everything and rooted again but the same thing happened. What do you think are the causes of this problem? – E.Canberk Dec 8 '18 at 0:25
  • It could be a few things what app? You should really ask it as another question with detailed information. Increasing your odds on finding a solution faster. – Bo Lawson Dec 8 '18 at 1:29
  • I have tried to run many app such as csploit, zanti, wifi kill, netcut, luckypatcher, etc.App asks for root access, magisk gives the access. Then program doesn't do anything or crash. – E.Canberk Dec 8 '18 at 1:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.