0

I accidentally deleted the system app com.samsung.android.MtpApplication from my rooted phone running Lollipop 5.1.1 using Titanium Backup. I had a backup but when I tried to restore it, it failed with an "App not installed" message.

I also added the app to system/app through ES File Explorer but it probably needs to be added to the phone's apps DB (considering it didn't show up as a system, nor a user app even after rebooting) and I'm not aware of how to do that.

Now, I'm stuck with a rooted phone that cannot connect to Windows through the MTP Application, but have a backup of said app. How can I install it manually

  • after having placed the APK in /system/app, have you rebooted? That's a required step for that approach. – Izzy Dec 8 '18 at 15:55
  • @Izzy yes, I did. If this doesn't get solved, is there another way to access my phone's media from my PC without MTP installed? Using PTP it doesn't seem to show up either. – Outman Dec 8 '18 at 16:08
  • 1
    You could use adb and, with the help of some app even good old UMS. To be honest, I feel MTP rather being a pain in the a**. My computer runs Linux, so I use adbfs and mount my Android devices directly. – Izzy Dec 8 '18 at 19:20
  • What devices is it? Looking around for the file location. I found a few different locations depending on the device. Like s7 it at: /system/priv-app/MtpApplication/MtpApplication.apk=com.samsung.android.MtpApplication also the Note 3: /data/data/com.samsung.android.MtpApplication and /system/apps you have to mount the system as rw get apk to the right location. I think its the priv one because its after 4. Whatever. Then verify permissions and you reboot and you should be good to go. – Bo Lawson Dec 9 '18 at 3:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.