0

I have a G930A, un-rooted, running AT&T's version of Oreo (8.0.0). I received an OTA update over the weekend and cannot use Google Calendar since--app force stops.

I also cannot do a calendar insertion from Tasker.

I have, of course reinstalled, cleared system cache, twiddled permissions, even factory reset, but am getting nowhere. Wife's phone has same update, but calendar is working fine.

Baseband G930AUCS8CRK1

Build R16NW.G930AUCS8CRK1

Security patch level November 1, 2018

Any thoughts?

  • Uou could could try but first Sync your calendars by going into Settings/Accounts/Google/menu in upper right corner and tap sync now. Also, just to ensure all basses are covered. Go down to calendar once it finishes synching untick calendar and then re-tick calendar. Also back up calendars data if wanted. This will erase all calendar data but once it re-sync it should come back. Go to Settings/Apps/upper right hand corner menu click show system app. Go down and find Calendar, Calendar Storage and Google Calendar Syncronization apps. In this order Clear cache, Force stop, Clear data. – Bo Lawson Dec 8 '18 at 23:57
  • Thank you, Bo, for the reply! Sadly, this did not do the trick. I did notice, while looking at your response, that I do not have a "calendar" entry among the sync options--is just not there. I wonder if there's a way to force the OTA update to re-download and install. – Lance Eck Dec 9 '18 at 0:46
  • That is odd, calendar is the first option on all my devices under account -> google -> calendar sync.would think it would be a must syncing ability along e-mail. I wonder if that's part of the problem. I will look around the world wide web. – Bo Lawson Dec 9 '18 at 0:52
  • Going through the Google calendar support forum. It appears that if there is no syncing options and accounts then there is am issue. The fix all that seemed to be mainly suggested is settings > Accounts > Select Google > Tap Menu at the top right corner > Click Remove account. 4. Restart your device. 5. Add your Gmail account back: Go to your Phone settings > Accounts > Select Google > Tap Menu pat the top right corner > Click Add account. (Follow the prompts to add your Google account back to your phone) – Bo Lawson Dec 9 '18 at 1:36
  • 1
    Thanks, Bo! I tried re-adding the account after removing and rebooting, but still have no option for calendar sync. It's as if something was munged in the update. I'll also continue to look. Please feel free to hit me with any other thoughts--I appreciate them! – Lance Eck Dec 9 '18 at 2:23
2

Ended-up flashing the old firmware (links on xda) and redoing the OTA upgrade. Worked fine this time, which makes me think the first OTA file was munged. Doesn't AT&The have any error-checking built-in to their upgrade script?!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.