2

My wife, unfamiliar with rooting, agreed to update my rooted Moto C Plus when it requested an update. Needless to say, that didn't turn out well. It started booting to TWRP.

I tried finding a solution online. That led me to Troubleshooting: TWRP Boot Loop after OTA update in MOTO G4 (XT1621 Athene) where it gives the following method as a solution:

TWRP Method:

1 Go into TWRP -> Go to Advanced -> Go to Terminal: Enter

2 Please make a backup first of these files in SD card: `cp
/dev/block/platform/soc.0/7824900.sdhci/by-name/mota /sdcard/mota2
cp /dev/zero of=/dev/block/platform/soc.0/7824900.sdhci/by-name/misc
/sdcard/misc2`

3 Type this exactly: `dd if=/dev/zero
of=/dev/block/platform/soc.0/7824900.sdhci/by-name/mota HIT ENTER dd
if=/dev/zero of=/dev/block/platform/soc.0/7824900.sdhci/by-name/misc`
HIT ENTER

4 Restart the phone.

On my phone, there is no soc.0 in the platform folder, instead there is mtk-msdc.0. I tried searching online for a similar solution with the folder mtk-msdc.0, but I couldn't find any,except for https://jagadgetaholic.blogspot.com/2017/06/vernee-thor-e-twrp.html.

Desperate (not knowing which file to go with), I tried dd if=/dev/zero of=/dev/block/platform/mtk-msdc.0/11230000.msdc0/by-name/boot. That executed something. But later, when i restarted the phone, it stopped booting to TWRP. Instead, it is now just showing me this logo (Moto) screen (the one that shows first when you turn on the phone, before the TWRP) for about 30 secs or so, and then the phone restarts back to the same screen...restart... screen...and so on. Basically a bootloop, I believe it's called.

What do i do now? The fix i was looking for is one where i don't lose my files. Everything is on the internal memory. No SD card. I want to be able to get my phone to start working again without losing my files. If I could get it to start working again with everything just the way it was before this problem, i would be super grateful.

Please help!

Phone: Moto C Plus (xt1723) 2GB Ram 16 GB Internal memory

OS: Android 7

Flashing tool: MediaTek SP Flash tool v5.1644.00

migrated from superuser.com Dec 10 '18 at 22:08

This question came from our site for computer enthusiasts and power users.

  • 1
    We will need much more information to give good recommendations here. Please edit your question and include at least: Android version it is running, whether it is official TWRP? Also check and update the tags you've used to match your issue. – beeshyams Dec 11 '18 at 11:42
1

You just erased your boot image,

I think you should stick with the proper terminology. When reading from /dev/zero it simply yields an infinite amount of (ASCII) zero bytes (after all it's a character device). /dev/null when used to write to is much closer to what one could describe as a black hole. But those are two different devices with different semantics. ( 0xC0000022L - comment)

dev/zero is 'an infinite amount of zero bytes' in Android, DD is used for copying. Here's what you ran in English:

Copy ( IF ) Input File = Zero Bytes ( OF ) Output File = Boot File

You effectively flashed your boot with a series of zeros ( Erased ).

So now that's gone, you'll need to flash it back with Fastboot..

If your device has a locked bootloader, you'll need to flash it back via SP Flash Tool.

I am working on a solution using SP Flash Tool and the stock 7.0 boot image,


Ok before anything, do a complete backup of all regions using SP Flash Tool MTK Backup & Restore video guide

  • Download a stock boot.img
  • Download these repair files MT6737M Files
  • Open SP Flash Tool version 5.16 or newer

  • Extract the files to a folder (Folder1) on your PC

  • Extract your boot.img from the firmware and place it in your folder (Folder1)

  • Now you'll have four files

    • MT6737M_Android_scatter.txt
    • Preloader_xx.bin
    • recovery.img ( twrp )
    • boot.img ( stock )
  • Open the Scatter file in SP Flash Tool

    • It should automatically locate the files if no names have been changed
  • Unselect Preloader

    • You are only flashing boot & recovery
  • Select DOWNLOAD as the method of Flash

    • NEVER SELECT FIRMWARE UPGRADE ETC..
  • Turn Off The Device

    • Make sure Quick Boot is not keeping your device switched on
  • Place the USB end into your PC

  • Hit start in SP Flash Tool

  • Plug the other end of the USB into your device

  • Wait for Flash OK

P.S Please follow the backup guide to make sure if anything gets overwritten by an incorrect scatter file, we can restore it.

Tips : Each connection is a called a Handshake with the preloader, you can only use one handshake per action in SP Flash Tool, so you'll need to disconnect the usb and reconnect it to make another preloader handshake for any following action.

Do not move your device while it's flashing, try to keep the usb cable as still as possible.

  • Ahhh that makes sense. Thank you so much for clarifying that. Although i consider muyself a black blet in Googlefu, with this one, i was able to get zero info in 4 days as to what exactly i did. – JJrussel Dec 11 '18 at 18:03
  • OK...lets see. I am on Nougat, so Android 7. If there are different versions of Nougat, then i have no clue which version. Before this problem, i'd rooted the phone using SP Flash Tool using this guide. Does that mean my bootloader is unlocked? Title says "Guide for Install TWRP & Root Moto_C_Plus With Locked Bootloader" so i'm going to assume it's locked. Can i flash boot thru SP wile preserving my data (including my Google account)? How? – JJrussel Dec 11 '18 at 18:26
  • Yes you can.... If you are absolutely sure that you have a correct scatter file, you can grab the boot image from a stock firmware online and use the Advanced Mode ( Write Memory ) Tab to write the boot.img back to the device or use DOWNLOAD mode, and only select to flash the boot.img – Zillinium Dec 11 '18 at 21:56
  • Advanced Mode is accessed by pressing CTRL + ALT + V in SP Flash Tool... I made a video on doing a complete backup using readback and restore using write memory... here's the link if you're interested... youtu.be/e2_U68EGSlY – Zillinium Dec 11 '18 at 21:57
  • 2
    I think you should stick with the proper terminology. When reading from /dev/zero it simply yields an infinite amount of (ASCII) zero bytes (after all it's a character device). /dev/null when used to write to is much closer to what one could describe as a black hole. But those are two different devices with different semantics. – 0xC0000022L Dec 11 '18 at 22:47

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.