1

In the process of rooting my Nextbit Rboin, I unlocked the bootloader, and wiped it so I only have TWRP on it.

I have an LOS zip ready but I dont know how to get it on the device. I have installed minimal adb and fastboot, and after that adb did not work I also installed 15 seconds adb installer.

fastboot -1 0x2c3f devices

shows my device but

adb push los.zip /sdcard/

gives me the error no devices/emulators found.

adb shell

gives me same error no device found.

fastboot update los.zip

gives error does not contain android-info.text

How to get the zip on to the robin? Should I be in fastboot or twep when I run adb? neither work.

1

If fastboot devices shows your device, adb cannot work (and vice versa).

You need to boot to recovery (TWRP). Then you can push the ZIP via adb push and flash it using TWRP's menu (but fastboot devices then will show nothing, which is fully normal).

If ADB doesn't work when booted into TWRP, check TWRP's settings whether ADB is disabled. It might also be that, while booted into recovery, your Robin presents a different ID then when in fastboot, so you'd need to configure that (or, in case of Windows, need another reboot for the corresponding driver to update/activate).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.