2

I've done a few hours worth of research and have been unable to find a clear answer. Hoping something in the community here might be able to help:

  • Verizon Galaxy S7 Edge (Oreo with latest Verizon updates) randomly got itself stuck in a boot loop after plugging in to charge one night.
  • Boots to lock screen just before loading "swipe unlock dots" gives an error message saying "Setup wizard has stopped" with an option to "Close App" and then reboots within a few seconds.
  • Stock OS, no root, no custom recovery etc.
  • Care mostly about trying to retrieve some pictures and documents more than anything else.
  • I THINK (99% sure) I have USB debugging enabled but can't get far enough into phone to confirm.

Things I've tried:

  • Plugging USB into computer shows up as CD-Rom drive (suggests that USB mode isn't set to MTP which I think might have been changed on me in the last OS or security Update)
  • Safe mode/boot results in same bootloop issue
  • Cleared system cache from Debug mode, no change.
  • Running "adb devices" shows device attached (momentarily prior to rebooting)
  • Initially thought it was a problem with the security module so I (perhaps in a poor decision) ran the command "locksettings clear --old xxxx" which I (unfortunately don't recall) must have been preceded by an "adb shell" command.
  • This actually WORKED as I must have timed it just right to go through in the 2 secs prior to the phone rebooting.

Current State:

  • All efforts to repeat the same ADB commands as before show up as "Device offline" and I can't seem to get more than that.
  • Bootloop continues.
  • Can access Debug modes and Download modes successfully, but don't know what to do here.

Ultimate questions:

  • Is there an ADB command to change the USB mode from Charge Only to MTP that I can try to issue and maybe get the phone to recognize quickly prior to rebooting?
  • I'm relatively new to the ADB world, so am I going down the wrong path here? Should I be trying something else?
  • What other options might I have (BESIDES a full restore and loss of all data), or am I pretty much done for?

Appreciate anyone that can take the time to provide some feedback. I'd be much obliged and sincerely thankful.

SAD UPDATE: I brought the phone to my local "ubreakifix" store - the service that Samsung specifically refers customers to for technical/repair issues. They attempted to do something (update software or something along those lines, but promising not to erase data). Unfortunately, whatever they did seems to have now DISABLED USB Debugging. I'm willing to try any other suggestions that those more knowledgeable than me might suggest, but I'm quickly losing hope.

  • What about installing TWRP from download mode then copying your data to either an SD card or a computer ? Besides, does your phone get hot before rebooting? There may be a hardware failure (Happened to my Galaxy Tab years ago) – esQmo_ Dec 18 '18 at 6:20
  • If you had sync enabled, your photos might have been backed up by Photos app. Have you tried verifying that this is not the case? – Firelord Dec 19 '18 at 7:31
1

Did you try ADB pull? If you know the folder your files are in, you can try to pull them out. (/sdcard is the name of Internal Storage folder) If it works you should see the file you pulled in the ADB directory.

adb pull /sdcard/your-files

Also, this can be an issue related to the Setup Wizard app. If that is the case, the following ADB command should work.

adb shell pm hide com.google.android.setupwizard

If it works you may spot some errors and missing features, but MTP should work. You might have to factory reset or reflash (not sure if that is possible on Verizon devices) to fix the errors.

You can try contacting Samsung and Verizon customer support, and if you prove the device ownership to them (the bill or invoice should do) they might use their debug protocols to recover your files, but I'm not sure about this as I never tried it.

If these doesn't work, I don't see any other methods unfortunately. (@esQmo_ It is currently not possible to flash TWRP in a Verizon S7 Edge because there is no known method to unlock the bootloader)

To answer your ultimate questions:

1: There is a way to switch USB mode from ADB, but it requires root. Also, I'm surprised that your device shows up in ADB. It shouldn't if the device is in charge only mode. My guess is that your device is in MTP mode, but it doesn't show the files because of a screen lock or something, and your OS interprets it as a CD ROM Drive.

2: Not at all. The only way you may have a shot at recovering this is ADB. You can't do anything in Download or Recovery modes (I think you referred to Recovery as Debug?) because it will compromise data security.

3: The options I mentioned above are the only ones I could think of.

Also, I suggest waiting for any other answers before resetting or reflashing, as they might have methods I missed. Good luck!

  • Super helpful post and appreciate your input. Unfortunately I can't seem to keep the phone on long enough to run any ABD commands (unless I can sneak a quick one in before it reboots). Seems to keep saying "Device Offline" now though. I'll try the "setupwizard" cmd you mentioned and see if I can get it to go thru. Called Samsumg - LESS than helpful. Considered TWRP too, but the point you mentioned is exactly what I was concerned about. Not sure it can be done, or at least not without wiping data. I'm holding off on system restore as long as I can. Will update as I can. – Argonax Dec 18 '18 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.