Or at least I think that's the problem. For weeks now the time on my Pixel has been popping all over the place, without me intervening, always off by exactly one or more hours in either direction. For long stretches the time will be correct, but then it'll start jumping around.

Moments ago my phone said 11:07am. Now it's the correct time, 3:07pm. I few minutes prior to that it was 5pm-something. Interestingly, I was trying to use the Google Authenticator app, which doesn't seem to work when the time is incorrect. Without me doing anything, it finally figured out the correct time and the Authenticator app worked.

Additionally, yesterday the time was incorrect when I launched Waze and set a route. After my drive started the time randomly fixed itself, but Waze got confused and my 'time to destination' didn't budge, although the route map continued to update. Crazy, and Waze should use their server clock over the device clock anyway.

Under Date & time I, naturally, have Automatic time zone enabled, as well as Automatic date & time. I suppose I could disable Automatic time zone, but that's a somewhat-annoying work-around, not a fix.

Has anyone see this before? Any suggestions as to what might be the problem?

Note: I'm running Android v9. I cannot remember exactly when I upgraded and have no idea if that coincides with the timing of this problem.

Update: I disabled "Automatic time zone," leaving "Automatic date & time" enabled, and the issued reoccurred, so it's not that. I suppose I could disable them both, but that seems like it would be a hassle.

  • 2
    This may not be helpful, but my son's Nokia 6.1 (also with Pie 9.0) started having the same issue after the November security update... So this maybe a bug in Pie under the right conditions. The only fix we have found is turn off Automatic Time Zone for now.
    – acejavelin
    Commented Dec 17, 2018 at 23:56

1 Answer 1


Just did a quick search on the Issue Tracker - you might want to follow these threads and/or contribute a bug report for them:

Unfortunately yes you'll have to disable auto time zone for now.

  • 1
    This really feels like a bug, so great find. It's not reproducible and occurs randomly. It's frequent enough that it's annoying. Commented Dec 18, 2018 at 17:33
  • 1
    It is a shame that Google closed your requests for this bug. I overslepts 2 hours of work because of this today. Cell tower sends GMT+0 and it was GMT+1+Daylight savings making it 2 hours shift. Trying to explain this bug is equal to "my dog ate my homework". Pretty annoying
    – Large
    Commented Apr 18, 2019 at 6:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .