1

This is the 3rd time my sd card has become read-only. I can still transfer files from it but not into it. I have tried all methods in the internet such as Diskpart and other softwares.

May I ask if you have encountered this as well and how did you fixed it?

Phone: Huawei Y6 2018 [Android 8.1 Oreo]

Sandisk SD Card Class 10 32 GB

9
  • 2
    What's the phone model, android version, SD card's model? Does it become read-only when you use a specific app? Dec 18, 2018 at 6:34
  • 1
    Either the two don't like each other (wouldn't be the first time; in this case try a different brand of SD card) – or your card is about to die (and was mounted read-only due too many errors). There might be a third option, but it escapes me at the moment.
    – Izzy
    Dec 18, 2018 at 6:41
  • @ReddyLutonadio Huwaei Y6 2018, Android 8.1, not in a certain app, but also when it is read in a computer. Dec 18, 2018 at 7:42
  • @Izzy are there ways to fix those errors? Dec 18, 2018 at 7:42
  • if you have a terminal emulator, can you provide the output of mount | grep -i storage and mount | grep -i sdcard Dec 18, 2018 at 8:44

0

You must log in to answer this question.

Browse other questions tagged .