2

Everything was working fine on my Lenovo tablet until a couple of weeks ago when Play Store was no longer able to update the gmail app. It usually just was left hanging. Other apps seemed to update just not the google ones.

Anyway, I followed all the various suggestions provided in order to try and fix it but still have the problem. One of the things that was suggested was to uninstall updates to Play Store which I did and am now back with version 5.1.11 I think it is. Unfortunately it's stuck here and is making no attempt to update.

I then tried downloading the latest compatible Play Store from a reputable site but that won't install either... it just hangs and after about 10 mins says "App not installed". Attempting to update google via the Play Store hangs for some minutes and then eventually gives a 504 error.

I've tried powering my router off and back on again and also used my neighbour's wifi but still get the 504 every time.

Not sure where to go from here. I've tried a whole heap of so-called fixes off the internet but the problem remains.

Any help, other than suggestions of factory reset, would be appreciated.

  • Have you tried going to Settings > Applications > Google Play Store, once there try clearing cache and data. Then reopen Play Store. You can locate these options where you went to "uninstall" the updates. – anonymous coward Dec 18 '18 at 21:41
  • Yep, I've tried clearing cache and data but it made no difference. – IanA Dec 19 '18 at 0:40
  • Check this link: android.stackexchange.com/questions/35062/… – Reddy Lutonadio Dec 19 '18 at 1:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.